HP41CV faux contact alimentation pile

Une machine en panne, cassée ? Un mode de fonctionnement incompréhensible ? Exprimez-vous ici

Modérateur : Politburo

Avatar de l’utilisateur
Danny
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 623
Inscription : 28 déc. 2013 17:34

Re: HP41CV faux contact alimentation pile

Message par Danny » 02 nov. 2020 15:57

Normalement en testant je devrais constater une continuité électrique entre les 2 bornes extrêmes (gauche et droite) du flex, vous confirmez ? :geek:
Casio fx-702P, 750P, 880p, 3900p, 7000G, 6000G, 6500G, 6800G, 8500G, 4500P, 9900GC, 9950GB +, Graph 100+ USB
HP 35, 45, 65, 21, 25, 67, 33E, 41C, 41CX, 20S, 42S, 28S, 32S, 32SII, 48SX, 48S, 48G, 48GX, 48G+, 50g, 35s, Prime
Sharp PC-1500A, PC-1262, EL-9000 | Tandy PC-7

Avatar de l’utilisateur
bernouilli92
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 4683
Inscription : 21 nov. 2012 14:03
Localisation : Ile de France

Re: HP41CV faux contact alimentation pile

Message par bernouilli92 » 02 nov. 2020 16:20

Danny a écrit :
02 nov. 2020 15:57
Normalement en testant je devrais constater une continuité électrique entre les 2 bornes extrêmes (gauche et droite) du flex, vous confirmez ? :geek:
Non, tu dois avoir une continuité entre les deux bornes du milieu. Et une continuité entre la borne de droite et la partie du flex tout en bas que tu peux atteindre à l'aide d'une épingle car il faut percer le vernis. Et la même chose pour la borne de gauche.
HP, Casio, Sharp, Psion, quelques TI et divers autres

Avatar de l’utilisateur
Danny
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 623
Inscription : 28 déc. 2013 17:34

Re: HP41CV faux contact alimentation pile

Message par Danny » 02 nov. 2020 17:30

Ok je vois, le but est de voir si la partie "charnue" qui est en contact avec les piles est bien reliée au circuit du flex lui-même (ou si en soudant ça n'a pas fait fondre la couche de plastique et isolé le truc, c'est ça ?)
Je vais chercher une aiguille :P :D

Pour les bornes du centre yes, y a bien continuité.
Casio fx-702P, 750P, 880p, 3900p, 7000G, 6000G, 6500G, 6800G, 8500G, 4500P, 9900GC, 9950GB +, Graph 100+ USB
HP 35, 45, 65, 21, 25, 67, 33E, 41C, 41CX, 20S, 42S, 28S, 32S, 32SII, 48SX, 48S, 48G, 48GX, 48G+, 50g, 35s, Prime
Sharp PC-1500A, PC-1262, EL-9000 | Tandy PC-7

Avatar de l’utilisateur
FlyingNono
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 1845
Inscription : 05 déc. 2003 21:26
Localisation : (encore dans les cartons)

Re: HP41CV faux contact alimentation pile

Message par FlyingNono » 02 nov. 2020 21:29

Salut,
Je suis en train de trier mes machines, et j'ai une 41 qui marchait en début de semaine et qui donne maintenant des signes d'encéphalite progressives :
- démarrage difficile : parfois ok, parfois rien, et quand c'est bloqué, il faut retirer les piles plusieurs heures
- quand ça démarre il y a un fonctionnement presque ok mais la fonction cat ne fonctionne pas correctement :|
-> y a t'il des composants réputés fragiles à changer ?
a+
J'ai un phaseur, un générateur de changement d'état physique, je n'hésiterai pas à m'en servir !

Avatar de l’utilisateur
Gege34
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 1451
Inscription : 03 oct. 2014 11:19
Localisation : 31

Re: HP41CV faux contact alimentation pile

Message par Gege34 » 02 nov. 2020 21:58

Dans ton cas FlyingNono je dirais que le problème vient de la carte mère (le cat qui fonctionne mal qui me fait penser à ça).
Malheureusement il y a beaucoup de composants propriétaires sur cette carte. Tu peux essayer de remplacer les capas qui se trouve dessus.
Du Commodore (64/128/Amiga), De la HP (28/41/48/50/71/75/200/Prime) et quelques autres trucs (Ti, Canon X07, Psion, Casio, Palm, Thomson, Exl)

Avatar de l’utilisateur
FlyingNono
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 1845
Inscription : 05 déc. 2003 21:26
Localisation : (encore dans les cartons)

Re: HP41CV faux contact alimentation pile

Message par FlyingNono » 02 nov. 2020 22:47

je vais regarder si un schéma existe :geek:
J'ai un phaseur, un générateur de changement d'état physique, je n'hésiterai pas à m'en servir !

Avatar de l’utilisateur
Gege34
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 1451
Inscription : 03 oct. 2014 11:19
Localisation : 31

Re: HP41CV faux contact alimentation pile

Message par Gege34 » 02 nov. 2020 22:58

FlyingNono a écrit :
02 nov. 2020 22:47
je vais regarder si un schéma existe :geek:
Service manual et un schéma plus clair que celui présent dans le 1er. Bonne lecture.
Du Commodore (64/128/Amiga), De la HP (28/41/48/50/71/75/200/Prime) et quelques autres trucs (Ti, Canon X07, Psion, Casio, Palm, Thomson, Exl)

Avatar de l’utilisateur
FlyingNono
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 1845
Inscription : 05 déc. 2003 21:26
Localisation : (encore dans les cartons)

Re: HP41CV faux contact alimentation pile

Message par FlyingNono » 02 nov. 2020 23:46

Superbe!
J'ai tout ce qu'il me faut pour vérifier les composants
Merci
J'ai un phaseur, un générateur de changement d'état physique, je n'hésiterai pas à m'en servir !

cgh
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 2275
Inscription : 30 août 2011 12:23
Localisation : Vous êtes ici -> .

Re: HP41CV faux contact alimentation pile

Message par cgh » 03 nov. 2020 10:43

FlyingNono a écrit :
02 nov. 2020 21:29
- quand ça démarre il y a un fonctionnement presque ok mais la fonction cat ne fonctionne pas correctement :|
La ROM peut aussi etre corrompue. J'avais une HP41C qui fonctionnait bien sauf le GTO .. qui plantait. En fait, avec un Clonix programme en module de service, le diagnostic est tombe: mauvaise checksum sur une des ROM :(
Bon, c'est une 41CL maintenant :mrgreen:
Il y a ceux qui voient les choses telles qu'elles sont et se demandent pourquoi, et il y a ceux qui imaginent les choses telles qu'elles pourraient être et se disent... pourquoi pas? - George Bernard Shaw
J'adore parler de rien, c'est le seul domaine où j'ai de vagues connaissances ! - Oscar Wilde
Ce n'est pas parce que les choses sont difficiles que nous n'osons pas. C'est parce que nous n'osons pas que les choses sont difficiles. - Sénèque

Avatar de l’utilisateur
Danny
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 623
Inscription : 28 déc. 2013 17:34

Re: HP41CV faux contact alimentation pile

Message par Danny » 24 nov. 2020 17:15

J'ai enfin pris le temps de démonter ma 41C avec son flex pourri... et en effet il est bien gangréné du côté de la borne la plus atteinte :

IMG_8457.jpg
IMG_8457.jpg (142.13 Kio) Consulté 1850 fois
IMG_8455.jpg
IMG_8455.jpg (169.31 Kio) Consulté 1850 fois

Et de l'oxydation s'était propagée sur le PCB :

IMG_8458.jpg
IMG_8458.jpg (235.96 Kio) Consulté 1850 fois

J'ai nettoyé tout ça du mieux possible, et j'ai vérifié ensuite que le courant passe bien entre la zone de contact avec le flex au bout de chaque piste et un peu plus loin sur la la même piste : tout est ok.

Qques gros plans après une 1ère passe de nettoyage (j'ai nettoyé encore mieux par la suite au vu de ces photos) :

IMG_8462.jpg
IMG_8462.jpg (142.91 Kio) Consulté 1850 fois
IMG_8460.jpg
IMG_8460.jpg (89.64 Kio) Consulté 1850 fois
IMG_8461.jpg
IMG_8461.jpg (102.09 Kio) Consulté 1850 fois

J'ai aussi viré le flex, et un bout de l'excroissance en plastique du côté des contacts des piles est parti avec (celui du côté le + atteint) :

IMG_8463.jpg
IMG_8463.jpg (121.65 Kio) Consulté 1850 fois

Les autres font un peu la gueule aussi, il en reste un seul en état initial.
Vous pensez que je devrais raboter les autres pour égaliser, et tenter de remettre un nouveau flex par-dessus tel quel, comme disait steste ? :
steste a écrit :
02 nov. 2020 14:45
Pourquoi ils ont mis ces petits carrés de plastique noir sous le plastique flex, soit disant pour améliorer le contact ?

Toutes les pannes partent de la, vu que c'est la zone de contact.

Faudrait déglinguer le flex, supprimer les petits cubes et remonter. (et exagérer un peu les ressorts)
Mais avant d'investir dans un nouveau flex, je pourrais tenter d'allumer la machine en branchant du jus sur les bornes du côté, non ? (celles de la fameuse prise d'alimentation qui a disparu sur les modèles suivants).
Dernière édition par Danny le 24 nov. 2020 19:41, édité 1 fois.
Casio fx-702P, 750P, 880p, 3900p, 7000G, 6000G, 6500G, 6800G, 8500G, 4500P, 9900GC, 9950GB +, Graph 100+ USB
HP 35, 45, 65, 21, 25, 67, 33E, 41C, 41CX, 20S, 42S, 28S, 32S, 32SII, 48SX, 48S, 48G, 48GX, 48G+, 50g, 35s, Prime
Sharp PC-1500A, PC-1262, EL-9000 | Tandy PC-7

Jean-Louis
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 374
Inscription : 14 mai 2010 19:15
Localisation : Lyon

Re: HP41CV faux contact alimentation pile

Message par Jean-Louis » 24 nov. 2020 18:14

Danny a écrit :
24 nov. 2020 17:15
J'ai nettoyé tout ça du mieux possible, et j'ai vérifié ensuite que le courant passe bien entre la zone de contact avec le flex au bout de chaque piste et un peu plus loin sur la la même piste : tout est ok.
Nettoyer ne suffit pas ; si on ne veut pas constater des dégâts quelques mois plus tard, il faut neutraliser l'acide.

Perso, je répands un mélange d'eau et de bicarbonate de soude (ou je fais tremper dedans, si la pièce est petite).
Je laisse agir quelques minutes, en frottant avec une vieille brosse à dents, puis je rince à grande eau et puis je sèche à l'air chaud (sèche-cheveux).

Avatar de l’utilisateur
Danny
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 623
Inscription : 28 déc. 2013 17:34

Re: HP41CV faux contact alimentation pile

Message par Danny » 24 nov. 2020 19:55

Oui pour l'instant j'ai utilisé du vinaigre blanc, mais je pourrais finir avec du bicarbonate de soude non ?
Pour le rinçage à grandes eaux par contre ça va être plus dur :D
Casio fx-702P, 750P, 880p, 3900p, 7000G, 6000G, 6500G, 6800G, 8500G, 4500P, 9900GC, 9950GB +, Graph 100+ USB
HP 35, 45, 65, 21, 25, 67, 33E, 41C, 41CX, 20S, 42S, 28S, 32S, 32SII, 48SX, 48S, 48G, 48GX, 48G+, 50g, 35s, Prime
Sharp PC-1500A, PC-1262, EL-9000 | Tandy PC-7

Jean-Louis
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 374
Inscription : 14 mai 2010 19:15
Localisation : Lyon

Re: HP41CV faux contact alimentation pile

Message par Jean-Louis » 25 nov. 2020 01:44

Le vinaigre blanc est acide ; un acide, ce n'est pas l'idéal pour neutraliser un autre acide.
Le bicarbonate de soude neutralise l'acide en le transformant en base + eau.
Oui, il est possible d'appliquer le bicarbonate après passage au vinaigre blanc ; le bicarbonate aura juste plus d'acide à neutraliser que sans usage du vinaigre.

je ne sais pas si ma citation de l'eau a été prise pour une blague ; mais c'est vrai, dans un cas semblable, je passe l'engin sous le robinet après traitement, pour le rincer.

Avatar de l’utilisateur
Danny
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 623
Inscription : 28 déc. 2013 17:34

Re: HP41CV faux contact alimentation pile

Message par Danny » 30 nov. 2020 20:12

Bonsoir, I'm back :)

J'ai essayé d'alimenter ma 41C en amenant le jus aux fameuses 2 bornes de l'alim sur le côté, qu'elle possède encore, mais même avec l'aide d'une paire de mains supplémentaire c'est trop galère d'arriver à bien faire contact sur ces 2 bornes qui affleurent à peine (difficile d'être sûr que c'est ok) et appuyer sur ON de l'autre côté du boîtier en même temps... bref j'ai pas réussi :mrgreen:

Mais de toute façon, j'ai un doute vu que j'ai viré le flex : est-ce que le flex ne sert pas justement aussi à relier quelques pistes du PCB entre elles, même si on n'a pas de piles dans le bouzin :?:

IMG_8517.jpg
IMG_8517.jpg (96.29 Kio) Consulté 1611 fois
Casio fx-702P, 750P, 880p, 3900p, 7000G, 6000G, 6500G, 6800G, 8500G, 4500P, 9900GC, 9950GB +, Graph 100+ USB
HP 35, 45, 65, 21, 25, 67, 33E, 41C, 41CX, 20S, 42S, 28S, 32S, 32SII, 48SX, 48S, 48G, 48GX, 48G+, 50g, 35s, Prime
Sharp PC-1500A, PC-1262, EL-9000 | Tandy PC-7

Répondre

Revenir vers « Problèmes techniques »