Au chevet de mon Atmos [Résolu : Problème de DRAM]

Tous les Orics (bon y en a pas des masses, mais on nous l'a demandé gentillement)

Modérateur : Politburo

Symoon
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 57
Inscription : 01 déc. 2003 01:23

Re: Au chevet de mon Atmos

Message par Symoon » 09 mai 2010 18:46

Le nez, c'est parce qu'il est plus sensible à la chaleur que les doigts... Mais crois moi au bout de quelques minutes, ce n'était plus la peine, ça chauffait assez.
Bon courage dans ton diagnostic...

NightBird72
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 17
Inscription : 25 janv. 2010 22:45

Re: Au chevet de mon Atmos

Message par NightBird72 » 24 mai 2010 18:03

Les pannes de DRAM 4164 occasionnent toujours de très jolis motifs sur les écrans, comme c'est le cas ici (merci pour les photos). La panne décrite ressemble bien à une défaillance de DRAM. Si le 5V est bien présent sur les circuits intégrés, il faut laisser chauffer. Une DRAM défaillante est souvent en court-circuit et chauffe très fort. J'utilise le dos d'une phalange (plus sensible) ou le nez (sensible aussi !) pour repérer en première approche les puces défaillantes. A l'oscillo il est également possible de repérer les puces HS (la manip. est décrite dans le manuel technique mentionné plus haut).

D'après mon expérience, les trois CI situés au dessus des 8 DRAM peuvent également être en cause (74LS04 et 2 x 74LS257).

Un Oric, c'est assez increvable, et ça se dépanne toujours ! Les principales défaillances sont liées 1) aux DRAM (souvent à cause d'une mauvaise alim). 2) au processeur 6502A. De tous les Oric que j'ai dépannés (et il y en a), je n'ai jamais vu une ULA (le composant rare) HS.

Si vous avez la possibilité de venir à la visu Oric du 19 juin à Paris (http://www.oric.org/?page=ceo&PHPSESSID ... 3de535ce7a), je me ferai un plaisir de vous expliquer tout ceci.

Amitiés à Symoon.

PS : un autre truc : si vous avez des DRAM 4164 OK, vous pouvez essayer de les monter à cheval sur les DRAM supposées défaillantes, ça peut marcher pour identifier certaines puces HS.

genius
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 47
Inscription : 01 juin 2009 10:52

Re: Au chevet de mon Atmos

Message par genius » 24 mai 2010 19:01

Salut à tous,

Bon je joue beaucoup avec ma nouvelle carte HxC, mais j'ai fait quelques tests sur mon pauvre Oric et la je me suis cramé quelques petits poils de nez :D.
Bref pour dire que sur les 8 TMS 4164 il y en a bien 3 qui sont brulants par rapport aux autres. Donc merci pour vos conseils c'est bien la Dram qui doit être en hs sur certains modules (Probablement quand mon alimentation a cramé :? )

Bon maintenant il va falloir que j'en trouve, j'ai vu ca
http://www.jameco.com/webapp/wcs/stores ... ory=105010

Par contre il faut que je regarde mais il vaudrait mieux que je les trouve à la même vitesse que les miennes qui sont TMS 4164 -12wl Ap8414

En tout cas NightBird72 je note le 19 juin sur mon calendrier et je vais essayer d'y faire un tour.

++ Sébastien

genius
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 47
Inscription : 01 juin 2009 10:52

Re: Au chevet de mon Atmos

Message par genius » 25 mai 2010 23:57

Salut à tous,

Bon en fait je viens de trouver à mon boulot quelques vieilles cartes et la miracle 8 dram 4464 dessus, je vais voir si on peut faire l'échange avec les 4164 a priori sur les c64 cela se fait. (Il faut que je compare les "datasheet") et comme un miracle n'arrive jamais seul dessus il y avait aussi des supports simm 30 broches pour la memoire de mon atari ste :) je vais faire chauffer le fer à souder :wink:

++ Sébastien

NightBird72
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 17
Inscription : 25 janv. 2010 22:45

Re: Au chevet de mon Atmos

Message par NightBird72 » 26 mai 2010 21:49

Hello,

les 4164 sont des RAM dynamiques 65536 x 1 bit. Autrement dit, dans l'Oric, chacun des 8 boîtiers de DRAM voit 1 bit des 64 K de RAM.

Je pense que les 4464 sont des RAM statiques x 8 bits (à confirmer avec le nom du constructeur). En tout cas ça ne marchera pas dans ton Oric. Inutile d'essayer de le cramer un peu plus !

J'ai noté d'apporter à la visu du 19 juin une EPROM de diagnostic : en utilisant les fonctions minimales de l'Oric (CPU, VIA), elle détecte les DRAM HS et, si le PSG n'est pas naze, le haut parleur égrenne les numéros des puces avec leur état... 8)

A+

Avatar de l’utilisateur
gilles
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 2971
Inscription : 17 avr. 2007 21:25
Localisation : 44
Contact :

Re: Au chevet de mon Atmos

Message par gilles » 26 mai 2010 22:49

NightBird72 a écrit :
J'ai noté d'apporter à la visu du 19 juin une EPROM de diagnostic : en utilisant les fonctions minimales de l'Oric (CPU, VIA), elle détecte les DRAM HS et, si le PSG n'est pas naze, le haut parleur égrenne les numéros des puces avec leur état... 8)

A+
concept interessant... qui me donne une idée pour mon clone d'apple // HS...

genius
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 47
Inscription : 01 juin 2009 10:52

Re: Au chevet de mon Atmos

Message par genius » 27 mai 2010 01:18

Salut à tous,

Oui j'ai survolé les caractéristiques des rams et c'est pas vraiment les mêmes :roll: , bon je désespère pas je vais faire encore les poubelles ou je peux trouver des vieux CI :D

En tout cas pour le 19 juin je négocie avec madame et je devrais pouvoir me libèrer, je viendrai avec le mourrant voir le diagnostique du docteur :wink:

Merci à tous en tout cas de prendre le temps de répondre.

++ Sébastien

Avatar de l’utilisateur
mandrake
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 2299
Inscription : 27 avr. 2006 22:41
Localisation : Chateauneuf les Martigues en face d'Ajaccio
Contact :

Re: Au chevet de mon Atmos

Message par mandrake » 27 mai 2010 08:53

Rien n'est jamais perdu, tant qu'il reste quelque chose à trouver. (pierre DAC)
Ressources pour TI-99/4A et 4 tout court

genius
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 47
Inscription : 01 juin 2009 10:52

Re: Au chevet de mon Atmos

Message par genius » 27 mai 2010 13:17

Salut à tous,

Merci Mandrake pour les liens. Le premier c'est ce que j'avais trouvé. Les autres j'ajoute en favoris cela peut toujours servir :wink:

++ Sebastien

NightBird72
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 17
Inscription : 25 janv. 2010 22:45

Re: Au chevet de mon Atmos

Message par NightBird72 » 27 mai 2010 20:11

Ne jette pas les 4464, elles peuvent servir pour des Oric "creux" (Orics avec 2 boîtiers RAM 4 bits)... Plus rares que les versions à 8 boîtiers 1 bit...

Ca peut aussi servir à dépanner d'autres vieux micros !

Dans ton cas, c'est bien des 4164-15 (150 ns) qui peuvent faire l'affaire (si tu peux en acquérir un jeu de 8, c'est mieux - les 3 puces bouillantes sont sûrement HS, mais il peut y avoir d'autres DRAM défaillantes...)

A+

Thierry

genius
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 47
Inscription : 01 juin 2009 10:52

Re: Au chevet de mon Atmos

Message par genius » 02 juin 2010 10:01

Salut à tous,

T'inquiète je ne jette plus rien depuis un certain temps ce qui a le don d'énerver ma femme :) Toutes les vieilles cartes qui passent je récupère et je stocke en me disant ca peut toujours servir :D

Oui pour la ram je vais me commander des 4164 et faire un montage propre (Enfin je vais essayer :wink: ) avec des supports dil pour les barettes mémoires comme ca la prochaine fois je serai moins embété

++ Sebastien

genius
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 47
Inscription : 01 juin 2009 10:52

Re: Au chevet de mon Atmos

Message par genius » 11 mars 2011 22:25

Bonsoir à tous,

J'ai été trés trés trés lent (J'ai fait une petite pause, mes activités "retro" sont passées aprés mes travaux ) mais je tenais à vous donner des nouvelles, le malade se porte comme un charme, j'ai enfin tout réparé cette semaine.
J'ai eu du mal à dessouder les mémoires (Impossible au fer et à la tresse), mais avec mon décapeur thermique à peinture (Oui oui c'est un peu barbare mais ca marche), en chauffant l'arrière de chaque composant tout s'est décollé sans soucis (Enfin presque, j'ai une résistance qui est tombée toute seule :mrgreen: mais rien de grave, j'ai retrouvé d'ou elle venait :wink: ).
Aprés j'ai mis des supports pour les problèmes futurs, j'ai remplacé toutes mes mémoires par des 4164-20 et ce bel Atmos a retrouvé toute sa jeunesse :wink:
En tout cas merci à tous pour vos conseils et surtout l'aide de NightBird72 à la visu Oric (J'ai raté celle de cette année mais l'année prochaine je ferai tout pour y assister)

Je colle les liens des photos pour ceux que cela intéressent.

http://img846.imageshack.us/img846/9306/img0225i.jpg
http://img156.imageshack.us/img156/4629/img0227zd.jpg
http://img859.imageshack.us/img859/576/img0230.jpg
http://img846.imageshack.us/img846/4745/img0231vk.jpg


++ Sébastien

Avatar de l’utilisateur
kenneth
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 434
Inscription : 22 sept. 2010 13:48
Localisation : France PdD

Re: Au chevet de mon Atmos

Message par kenneth » 11 mars 2011 22:39

beau travail :geek: 8O :mrgreen:

Répondre

Revenir vers « Oric »