reconnaissance d'UFS NeXTSTEP sous Linux...

Des cubes et des boites à pizzas noires

Modérateur : Politburo

Répondre
Avatar de l’utilisateur
emond
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 442
Inscription : 15 févr. 2007 23:10
Localisation : Yvelines
Contact :

reconnaissance d'UFS NeXTSTEP sous Linux...

Message par emond » 09 févr. 2008 18:30

Il semblerait que le système de fichier UFS type NeXT (je n'ai pas essayé avec les autres) ne fonctionne plus dans les dernières versions de Linux ubuntu 7.10.

C'est bien curieux !
Avant, en 6.10 (ou sous Debian sarge) ca fonctionnait, et c'était relativement simple,il fallait activer via modconf dans le noyau de linux la gestion du FS :

loop + Montage d'un système de fichiers à l'intérieur d'un fichier
ufs + Système de fichiers UFS pour Sun/BSD/NeXT, parfois SysV

Et par la suite faire un mount (avec l'anti loop ou pas)...

Par exemple je monte un CDROM de NeXTStep 3.1 User :
root@pluton:/media# mount -t ufs -r -o loop -o ufstype=nextstep-cd /dev/cdrom /media/NeXT/
Je regarde le contenu du repertoire :
root@pluton:/media# ls -lsa /media/NeXT/
ls: lecture du répertoire /media/NeXT/: Erreur d'entrée/sortie
total 0

Erreur !!!

Qui a une idée ? a part installer un linux ubuntu plus ancien ? (ou mieux une Debian sarge)

Avatar de l’utilisateur
freddo
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 780
Inscription : 28 juin 2007 22:32
Localisation : Dijon, Bourgogne

Message par freddo » 09 févr. 2008 21:34

trouver le paquet logiciel qui doit exister au moins en source et le compiler et l'installer.... mais c'est vraiment bizarre quoique c'est la même chose pour le bfs il faut le compiler et l'ajouter car plus aucune distro ne le contient et ce même en additionnel :cry:

Avatar de l’utilisateur
emond
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 442
Inscription : 15 févr. 2007 23:10
Localisation : Yvelines
Contact :

Message par emond » 10 févr. 2008 01:55

Je regarderais demain...

mais c'est lié a un module du noyau qui gère les FS de type UFS (Système de fichiers UFS pour Sun/BSD/NeXT, parfois SysV)...
Et donc recompiler ne servira pas a grand chose... a part recompiler le noyau ;) et la c'est sport :P

la je viens de terminer la procédure pour faire une installation from scratch via le net (bootp et tftp).
Dernière édition par emond le 19 mars 2008 16:29, édité 1 fois.

Avatar de l’utilisateur
emond
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 442
Inscription : 15 févr. 2007 23:10
Localisation : Yvelines
Contact :

Message par emond » 18 mars 2008 15:56

bon et bien,
après moult tests,
il semblerais qu'il y ai un bug ou un abandon du support pour cette fonctionnalité :(

Je vais, réinstaller une vielle sarge pour voir...

Avatar de l’utilisateur
emond
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 442
Inscription : 15 févr. 2007 23:10
Localisation : Yvelines
Contact :

Message par emond » 19 mars 2008 14:40

Et bien c'est ca !!! Il y a un "non" support du format UFS NeXT !!!

Pour arriver a cette conclusion, J'ai réinstallé une Debian SARGE (3.1r0a) sur un PC (P3), j'ai fait les mises à jours, etc... Et, j'ai testé a chaque étapes de mise à jour (apt-get update, etc) si la reconnaissance du format UFS Next était encore valide !

Verdict : a partir du noyau 2.6.18 ca ne fonctionne plus...

La solution (pour moi sur ma machine dédiée), j'ai gardé une vielle version de noyau (2.4.27-2) et au boot je la choisis pour faire mes manipulations sur les CD-ROM ou Disque dur au format NeXT Step !

Ensuite, il est toujours possible de démarrer avec un noyau 2.6.18-6 pour utiliser l'interface graphique et les derniers outils...

Avatar de l’utilisateur
ben*.*
Fonctionne à 300 bauds
Fonctionne à 300 bauds
Messages : 97
Inscription : 21 oct. 2008 23:59
Localisation : Toulouse

Message par ben*.* » 26 oct. 2008 15:22

emond a écrit :Et bien c'est ca !!! Il y a un "non" support du format UFS NeXT !!!

Pour arriver a cette conclusion, J'ai réinstallé une Debian SARGE (3.1r0a) sur un PC (P3), j'ai fait les mises à jours, etc... Et, j'ai testé a chaque étapes de mise à jour (apt-get update, etc) si la reconnaissance du format UFS Next était encore valide !

Verdict : a partir du noyau 2.6.18 ca ne fonctionne plus...

La solution (pour moi sur ma machine dédiée), j'ai gardé une vielle version de noyau (2.4.27-2) et au boot je la choisis pour faire mes manipulations sur les CD-ROM ou Disque dur au format NeXT Step !

Ensuite, il est toujours possible de démarrer avec un noyau 2.6.18-6 pour utiliser l'interface graphique et les derniers outils...
en effet ufstype=nextstep-cd est bogue dans le 2.6.18 de debian etch mais marche avec le 2.6.24 ubuntu hardy. le support ufs next n'est donc pas totalement abandonne. apres j'ai pas teste avec les noyaux plus recent de debian testing ou backports.
"nos secrets sont tellement secrets que nous ne savons pas ce que nous faisons"

Avatar de l’utilisateur
zeograd
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 6
Inscription : 01 août 2008 17:14
Localisation : Damiatte (81)
Contact :

UFS toujours maintenu

Message par zeograd » 29 oct. 2008 16:12

Je te rassure, UFS est toujours maintenu sous linux.
Je viens de vérifier sous linux 2.6.26, il est présent sans aucune remarque sur un éventuel abandon (au contraire, il y a même un support d'écriture en phase expérimentale).
Rassure toi, il s'agit juste des distribution qui ne le compile plus par défaut. Tu l'as peut être en module (normalement il se charge au montage d'un tel volume, mais parfois ça loupe). Essaye un "insmod ufs" en tant que root pour essayer de le forcer.
Sinon, tu peux compiler juste le module "ufs" en récupérant les sources du noyau telles que configurées par ta distrib (en général tu as un paquet source des versions binaires packagées pour ce type de besoin).
Bon courage

Avatar de l’utilisateur
emond
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 442
Inscription : 15 févr. 2007 23:10
Localisation : Yvelines
Contact :

Message par emond » 23 nov. 2008 07:15

Tu a simplement regardé ou as tu confirmé par un test ?

De toute manière, je vais regarder de mon coté avec une version très récente pour confirmation... Avec par exemple une Ubuntu 8.10 :)

Ou une jigdo Debian :)

Avatar de l’utilisateur
emond
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 442
Inscription : 15 févr. 2007 23:10
Localisation : Yvelines
Contact :

Message par emond » 01 avr. 2009 13:33

C'est fonctionnel a nouveau !

J'ai vérifié avec une Debian 5.0 et une Ubuntu 8.10 !

Répondre

Revenir vers « NeXT »