Atari 260ST et 520ST, le début du commencement

Tous les ST, Falcon et compagnie (et même éventuellement les PC)

Modérateur : Politburo

Répondre
xoo
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 36
Inscription : 05 juin 2018 18:22

Atari 260ST et 520ST, le début du commencement

Message par xoo » 08 juin 2018 10:32

Je viens de découvrir que les premiers ST de la gamme ne disposaient pas de la totalité du TOS1.0 dans les ROM mais juste une sorte de bootstart servant à lancer le System Disk. Cette partie de l'histoire Atari 16-32b encore un peu connue de certains collectionneurs nous permet avec émerveillement de découvrir une autre facette de ces machines qui se révèle fort intéressante en fin de compte.

Je reprends sur ce topic la suite de la conversation pour ne pas encombrer le topic de dizzy << ICI >>

J'ai réussi à faire fonctionner le bootstart sur steemSE. Mais l'image du System Disk semble ne pas booter :? J'ai remarqué en émulation que le bootstart ne peux pas booter seul. Je ne sais pas si c'est le cas sur la vraie machine et donc nécessite le TOS1.0 de la D7 fournie avec. J'ai remarqué aussi que la D7 en question dispose d'un boot secteur autobootable avec un appel FDC systeme. Cela si le bootstart boote et exécute ce boot secteur confirmerait en partie ma théorie.

En attendant si quelqu'un avait la possibilité de dumper ces ROM d'origines en deux fichiers distincts nommés respectivement bootstart0 pour la lower et bootstart1 pour la upper cela nous permettrait de les "refaire" afin de les tester sur de vraies machines. 8)
Pièces jointes
Steem__042.png
Steem__042.png (8.28 Kio) Consulté 866 fois

Avatar de l’utilisateur
gilles
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 2745
Inscription : 17 avr. 2007 21:25
Localisation : 44
Contact :

Re: Atari 260ST et 520ST, le début du commencement

Message par gilles » 08 juin 2018 10:42

à mon avis il suffit de splitter le fichier octet par octet.
possible que ton soft pour programmer tes eproms en soit capable nativement, sinon on trouve des commandes pour le faire.
j'ai trouvé ca:
http://www.ezoflash.com/willem_info/for ... 1139922868
avec un lien vers un split2.exe
sinon ca se fait en qqs lignes de C, de perl... ou d'autre chose.

xoo
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 36
Inscription : 05 juin 2018 18:22

Re: Atari 260ST et 520ST, le début du commencement

Message par xoo » 08 juin 2018 11:59

Non, je pense qu'il vaut mieux partir des EPROM originales .C'est plus sûr. Fabrice93 a je pense le 520ST et mojopsyko le 260ST. Ce serait bien de leur demander ;)

Dans mes images, j'ai deux versions assez différentes, je suppose que l'une est celle du 520st et l'autre de son homologue européen le 260st... Mais dans ce lot une ne fonctionne pas...
J'ai commencé le désassemblage pour les comparer. Nous verrons bien comment fonctionne le bootstart dans les deux cas. Mais surtout comment se charge t-il de launcher le TOS1.0 et à quel emplacement dans la mémoire. Ensuite, éventuellement fixer le bug pour le fonctionnement en émulation. Nous verrons.

xoo
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 36
Inscription : 05 juin 2018 18:22

Re: Atari 260ST et 520ST, le début du commencement

Message par xoo » 10 juin 2018 10:33

Par un tour de passe-passe pas très correct et j'en suis confus :oops: (je corrigerai ça plus tard), j'ai réussi à booter la System Disk et donc voici à quoi ressemblait le desk de nos tout premiers ST :)
AtariTOSsystem_001.png
AtariTOSsystem_001.png (3.76 Kio) Consulté 809 fois
Pour info, les premiers 520STF avaient eux aussi le TOS sur 6 ROMs . Tiens!? :roll:

Avatar de l’utilisateur
gilles
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 2745
Inscription : 17 avr. 2007 21:25
Localisation : 44
Contact :

Re: Atari 260ST et 520ST, le début du commencement

Message par gilles » 10 juin 2018 11:12

Je dois avoir un tos disquette quelque part, sans doute avec un emulateur atari st pour amiga. Mais je ne sais pas quelle version, de memoire c’etait un 0.98 mais je confond peut etre... je chercherai ça à l’occasion

Répondre

Revenir vers « Atari ST et compagnie »