Pb joy2 sur Amiga 500

Tous les Amiga et dérivés, y compris la CD32

Modérateur : Politburo

Répondre
Moon
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 17
Inscription : 27 févr. 2011 16:21

Pb joy2 sur Amiga 500

Message par Moon » 25 oct. 2013 10:45

Salut tout le monde,

J'ai un petit soucis avec mon A500 et apres toutes ces annees de service je me suis dit qu'il etait temps de l'adresser.
Sur quelques jeux comme Total Recall ou Midnight Resistance la direction droite sur le joystick (port 2) est "saccadee", cad qu'au lieu de courir et faire un mouvement fluide, le perso avance-stop-avance...
Vu que cela ne concerne que qq jeux j'ai pense que c'etait probleme de timing software sur la lecture du port.

En checkant qq sites je me suis apercu qu'il y avait panne reccurente sur A500 avec le port 1 de la souris suite a du "hot plugging" qui fait sauter une resistance R401 de 4.7ohm
J'ouvre donc ma becane et la bingo je vois en effet que la resistance correspondante au joy 2 R408 avait bien brule. Je la remplace mais aucune difference.
En suivant ce schema je vois que 2 composants sont concernes par les ports joys: U4 Denise et U15 le 157.

La prochaine etape logique serait donc de remplacer U15 mais je me dis que si U15 etait defectueux sur l'entree de la direction droite (pin 4 - U15/4A) il devrait generer la meme erreur sur la direction bas (pin 2 - U15/4B) vu que les 2 signaux sont muxes, or ce n'est pas le cas.

Qu'en pensez-vous?
Il y a t il un software A500 pour tester les ports joys? Je pense pouvoir le transferer avec ce soft
Ou bien un script en CLI peut etre?

Merci

Répondre

Revenir vers « Commodore Amiga »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités