Claviers C128D

un pet, un vic, un 64...

Modérateur : Politburo

Répondre
Avatar de l’utilisateur
yvesbolo
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 440
Inscription : 23 mai 2002 15:48
Localisation : Lausanne, Suisse
Contact :

Claviers C128D

Message par yvesbolo » 14 juin 2007 11:15

Salut à tous,

Je suis en train de tester mes 128D... et j'ai quelques problèmes. Souvent à l'allumage, je reste avec un écran désespérément vide (je m'attendrais à avoir le Basic).

J'ai l'impression que c'est un problème de clavier. Je suis arrivé à cette conclusion en faisant des croisements clavier/machine. Est-ce que le clavier de cette bestiole est un élément fragile ?

Si c'est bien le clavier, y a-t-il quelque chose à faire ?

Help pliz
A+
Yves Bolo

Avatar de l’utilisateur
Mesachiel
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 26
Inscription : 18 août 2007 02:34
Localisation : Villeneuve la Guyard 89

Message par Mesachiel » 23 août 2007 00:41

je te proposerais bien un truc ....

une ou plusieurs touches en faux contact ou bloquées, une oxydation sur le connecteur, et un cia avec un coup dans l'aile ...

un coup de soufflette sur le clavier, du WD40 sur les connecteurs et recoup de souflette, demonter/remonter le CIA qui s'occupe du clavier ...

...
Image "Il ne faut pas confondre BITMAP et plan quéquette ..." (Milius Mesachiel - 1986)

Avatar de l’utilisateur
Carl
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 2542
Inscription : 04 janv. 2003 00:47
Localisation : www.dole.org
Contact :

Message par Carl » 23 août 2007 10:37

hi !
Yves, si tes essais croisés claviers / machines indiquent que cela vient du clavier alors les CIA 6526A n'y sont pour rien....

le clavier du 128D est effectivement fragile car il veillit pas très bien...

This is barely worthy of cbm-hackers, but for what it's worth, I had my
C128D keyboard open to fix up my barely-functional cursor left-right and
right-shift keys. The plastic frame holding the keys is attached to the
PCB and metal backplate via 21 tiny screws, which screw into small plastic
posts on the upper piece. A close look showed that most of these posts
have cracks in them, and hence are no longer holding the screws securely
(there are also some stress cracks/creases beginning on the upper plastic
key holder).

I believe that what's been happening is that when I press shift or
cursor-lr, it actually pushes the upper part away from the PCB instead of
making good contact -- the only way to make these keys work has been to
push down extremely hard.

My solution here was to drill a hole through the metal/pcb/keyboard holder
near the space bar and put a small 4-40 bolt+nut through, to hold the
assembly together (there are several raised plastic surfaces near the
space bar, giving a more secure/even point of contact). Time will tell if
this is effective; so far so good.

I also took a look at the plastic enclosure for the keyboard and sure
enough, cracks were forming in the much thicker plastic posts that receive
the screws.


carl

Répondre

Revenir vers « Commodore 8bits »