[atari 7800] Problemes video

Tout sur les consoles de jeux, liens, infos...Avec un thread par machine. Si la machine n'y est pas , créez le premier post la concernant dans ce forum

Modérateur : Politburo

Répondre
demether2
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 14
Inscription : 13 juin 2014 11:51
Localisation : sud ouest (40)

[atari 7800] Problemes video

Message par demether2 » 15 juin 2014 20:08

Salut,

Mon atari 7800 (version PAL, peritel RGB) fonctionne correctement hormis un probleme video :

Chaque jeu lancé (je n'ai que des cartouches 2600 pour tester) subit un affichage à dominante rouge/orangée, ainsi que des scanlines trés prononcées (comme un mauvais filtre d'émulateur, mais encore pire).

Sur asteroids (le jeu fournit en mémoire interne), ces défauts sont moins présents, mais l'affichage est loin d'etre parfait pour autant (problemes précédents atténués + un peu de flou)

J'ai démonté la console, je n'ai pas vu de patte coupée sur la prise femelle video. Les soudures me paraissent un peu seches toutefois.

J'ai également un peu trifouillé les deux potards présents sur la platine video, sans succés.

Le cable video me semble correct : si je le remue, rien ne change à l'écran, de plus le fait que le jeu en mémoire interne atténue fortement les symptomes principaux me fait penser qu'il est hors de cause.

L'idée que j'ai pour le moment, c'est de refaire les soudures de la prise video. Je ne vois pas trop quoi faire d'autre, dans un premier temps. Probablement aussi nettoyer le port cartouche ?

Merci pour votre aide, si vous avez de meilleures idées ;)

Avatar de l’utilisateur
DataPro
Fonctionne à 300 bauds
Fonctionne à 300 bauds
Messages : 215
Inscription : 28 mars 2013 09:29

Re: [atari 7800] Problemes video

Message par DataPro » 16 juin 2014 11:06

As-tu pu comparer l'image de cette Atari 7800 VCS avec une autre ?

demether2
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 14
Inscription : 13 juin 2014 11:51
Localisation : sud ouest (40)

Re: [atari 7800] Problemes video

Message par demether2 » 16 juin 2014 13:21

Malheureusement, non. J'ai juste regardé sur youtube et sur google image les screenshots et video "les moins pire".

Avatar de l’utilisateur
DataPro
Fonctionne à 300 bauds
Fonctionne à 300 bauds
Messages : 215
Inscription : 28 mars 2013 09:29

Re: [atari 7800] Problemes video

Message par DataPro » 16 juin 2014 14:16

Ok donc j'imagine que c'est ta première 7800 VCS.

Et bien rassure-toi, à mon avis elle n'a rien. L'image de la 7800 VCS est un peu particulière comme celle des Atari XE/XL.
Donc les scanlines c'est normal.
Pour la couleur, il faudrait voir mais bon, une 7800 VCS n'offre pas une image précise et nette et des couleurs péchues... ce n'est pas une Dreamcast !!

Astéroïds c'est vert (slime), orange et gris principalement. Pas de problèmes avec çà, c'est normal.

Avatar de l’utilisateur
SbM
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 4472
Inscription : 24 nov. 2004 22:49
Localisation : SQY (78), France
Contact :

Re: [atari 7800] Problemes video

Message par SbM » 16 juin 2014 15:00

Si tu pouvais faire des photos de ton affichage, ça permettrait de te dire si c'est OK ou pas.
http://sbm.ordinotheque.free.fr | http://www.mo5.com
"Un bon disque dur est un disque dur mort." (Général Cluster)

Avatar de l’utilisateur
gilles
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 3040
Inscription : 17 avr. 2007 21:25
Localisation : 44
Contact :

Re: [atari 7800] Problemes video

Message par gilles » 16 juin 2014 16:15

Je confirme que la 7800 ça bave un peu...
mais c'est une façon assez simple d'avoir les vraies couleurs pour les jeux 2600 (et pas les couleurs totalement bidon qui ressortent sur les 2600 secam).

demether2
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 14
Inscription : 13 juin 2014 11:51
Localisation : sud ouest (40)

Re: [atari 7800] Problemes video

Message par demether2 » 16 juin 2014 17:30

merci !

Je vais faire des photos. Mais je persiste, ya un probleme sur l'affichage. Si ce n'est pas le cas, et ben je vais plutot me chercher un atari flashback alors 8O

demether2
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 14
Inscription : 13 juin 2014 11:51
Localisation : sud ouest (40)

Re: [atari 7800] Problemes video

Message par demether2 » 16 juin 2014 20:40

Voilà les photos. Elles sont assez représentatives. Vous voyez la dominante de rouge sur les jeux cartouche (vcs2600), ainsi que les scanlines. L'image est un peu déformée sur les bords.

Image

Image


Sur le jeu 7800 intégré, vous pouvez voir que c'est pas le pied non plus coté affichage. On voit que le tramage rouge est aussi présent, mais moins. L'affichage bave pas mal aussi.

Image


J'ai essayé de toucher les potards de la platine fille rgb : soit j'améliore un peu l'affichage des jeux 7800 (moins flou) mais les jeux 2600 apparaissent en noir et blanc, soit j'ai un affichage "moins pire" sur les 2600 et c'est baveux à souhait sur le jeu 7800.

Du coup, à part refaire les soudures de la prise video, et nettoyer le port cartouche...Je ne vois pas de solution.

Avatar de l’utilisateur
gilles
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 3040
Inscription : 17 avr. 2007 21:25
Localisation : 44
Contact :

Re: [atari 7800] Problemes video

Message par gilles » 17 juin 2014 07:40

L'ecran est un cathodique?
On a l'impression qu'il tente de faire un désentrelacement et qu'il a du mal. Le genre de truc qu'une tele 100hz peut avoir envie de faire. Certains lcd sont aussi plutot mauvais à ce jeu.

demether2
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 14
Inscription : 13 juin 2014 11:51
Localisation : sud ouest (40)

Re: [atari 7800] Problemes video

Message par demether2 » 17 juin 2014 12:00

C'est une tv cathodique, acceptant le 50 et 60hz. Je passe toutes mes consoles (via peritel rgb) dessus sans soucis, de la master systeme à la dreamcast ;)

Pour terminer, l'affichage malgré ses défauts est parfaitement stable et ne scintille pas, rien n'indique un entrelacement.

Merci :wink:

Avatar de l’utilisateur
gilles
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 3040
Inscription : 17 avr. 2007 21:25
Localisation : 44
Contact :

Re: [atari 7800] Problemes video

Message par gilles » 17 juin 2014 13:30

si on regarde la version RGB:
Image

on se rend bien compte que c'est une adaptation un peu à l'arrache. donc il ne faut pas s'attendre à des miracles. La version n'est pas véritablement une RGB mais un réencodage PAL vers RGB avec le circuit qui devait être l'un des moins cher de l'époque.
En voyant ça je comprend pourquoi la couleur n'arrive pas toujours immédiatement sur les miennes, en fait le décodeur n'accroche pas tout de suite.
Je suppose que repiquer le signal PAL (ou mieux, en s-video) directement donnerait de meilleurs résultats.

Xavier
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 684
Inscription : 10 mars 2006 16:48
Contact :

Re: [atari 7800] Problemes video

Message par Xavier » 17 juin 2014 15:48

Avant de démonter la console, il serai bon de vérifier la connectique et le réglage du téléviseur...
Pour une image détériorée de ce type, avec une "caricature" grossière du signal, il faut d'abord vérifier les réglages, puis la connectique...
C'est tout bête, et c'est la première chose que l'on fait ... mais, souvent trop rapidement.
Si le téléviseur doit être réglé à ses maximum... contraste, lumière et couleur... il y a un problème de connectique.
En effet, le signal traité peu être un signal résiduel (un bruit électronique) que le téléviseur s'efforce de traiter.
Dans la plupart des cas, sur les péritels, se ne sont pas les broches (pliées ou enfoncées), mais la connexion de la masse qui est mauvaise.
Le signal, n'est pas franc, et très affaibli.
C'est parfois le car lors d'un court-circuit entre les broches et la masse...
Il faut donc vérifier la présence de court-circuit entre la masse et les fils RGB, syncho et le fil +5v/+12v de la vitesse de balayage.
Ressouder la masse sur le contour de la broche péritel et vérifier si la masse et connectée à la broche côté console.
Si le problème persiste, il faut bien évidement intervenir sur le convertisseur PAL/SECAM de la console, mais après avoir éliminé le problème de connectique.
Pour ce type de problème, rien ne sert de dérègler les potars RVB de sortie vidéo de la console.
On mets un petite goutte d'huile de vaseline sur les pistes des potars (surement sale>scratsh et mauvais contacts), puis on les tournent pour les dégriper et décoller la poussière de la piste... faire des allez et retour plusieurs fois. Placer le curseur au centre de potar, au milieu de la piste, ou à égale distance entre les points d'arrêt (généralement le réglage d'usine!). C'est à faire hors tension, bien sûre... les réglages d'affinement RGB, eux se feront machine allumée, mais généralement, après nettoyage les contacts sont bons, et il n y a pas besoin d'y toucher.
...

Avatar de l’utilisateur
gilles
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 3040
Inscription : 17 avr. 2007 21:25
Localisation : 44
Contact :

Re: [atari 7800] Problemes video

Message par gilles » 17 juin 2014 16:36

pour moi, vu la configuration de la carte fille, les potentiomètres ne sont pas des niveaux RGB car trop en amont du circuit. Le RGB n'est présent qu'à la sortie du décodeur.

Je suppose que l'un et l'autre sont les niveaux de chroma en mode 2600 et 7800 mais il faudrait le schéma précis pour en être certain, or cet adaptateur est spécifique au marché francais... il est donc peu documenté...

Avatar de l’utilisateur
gilles
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 3040
Inscription : 17 avr. 2007 21:25
Localisation : 44
Contact :

Re: [atari 7800] Problemes video

Message par gilles » 17 juin 2014 19:12

Quelques exemples, l'une de mes 7800 RGB en mode 7800 et 2600

L'asteroid intégré
Image

karatéka
Image

Jungle hunt 2600
Image

E.T. 2600
Image

Ca bave nettement plus en mode 2600 mais c'est très correct.
L'écran est un atari 1425, très très fin habituellement (ce qui va un peu accentuer l'effet de scanline).

demether2
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 14
Inscription : 13 juin 2014 11:51
Localisation : sud ouest (40)

Re: [atari 7800] Problemes video

Message par demether2 » 18 juin 2014 00:13

Ton résultat est 100 fois meilleur que ce que j'arrive à obtenir 8O Si j'arrivai à ça, je serai super content ! Quand tu vois ma photo d'asteroids, ce n'est pas une mauvaise photo, mais bien ce que je vois affiché à l'écran, malheureusement.

Concernant la "piste" tv en rade, ça m'étonnerai quand meme, comme je disai je passe une demi douzaine de consoles (de la MS sega à la dreamcast, pour avoir une idée des générations) sans aucun soucis, avec une image "parfaite", avec des réglages loin d'etre à fond. la TV est elle meme récente, ou plutot devrais je dire quasiment "new old stock" ( une tv neuve qu'on se réservait à cet usage unique, et qu'on a mis sur les consoles récemment).

Pour l'atari, j'ai bien sur testé directement sur la tv, sans passer par une triplite ou autre.

Je termine en disant que ces consoles (atari 2600 secam et 7800) m'ont été offert par un pote...qui les a trouvé sur le trottoir parisien. Ceci expliquant peut etre cela (sur le fait qu'une panne est belle et bien présente).

Je vais quand meme suivre le conseil sur la péritel, et démonter le coté péritel du cable 7800 pour vérifier la masse, ainsi que faire le huilage des potards. Je pense aussi refaire les soudures du port rgb qui me paraissent suspectes (seches) pour certaines.
Je suppose que l'un et l'autre sont les niveaux de chroma en mode 2600 et 7800 mais il faudrait le schéma précis pour en être certain, or cet adaptateur est spécifique au marché francais... il est donc peu documenté...
Je pense aussi. Ca expliquerai pourquoi un réglage particulier peut rendre les jeux 2600 monochromes, du coup, non ?


Je vous tiens au jus. J'attends la réception de ma commande de pannes fines pour m'y mettre.

Merci pour votre aide en tout cas, ça fait plaisir car chacun y va de son idée, c'est cool. J'aimerai vraiment l'arranger, d'une part pour jouer aux jeux 2600 de ma jeunesse (et en découvrir), mais également dans mon projet de dévellopement basic.

Répondre

Revenir vers « Toutes les consoles »