Dump de la rom IO_CPU

Tout sur le micro français le plus ambitieux mais si malchanceux

Modérateur : Politburo

Répondre
Avatar de l’utilisateur
Nico
Modérateur
Modérateur
Messages : 4380
Inscription : 17 mai 2002 09:25
Localisation : Nevers
Contact :

Re: Dump de la rom IO_CPU

Message par Nico » 02 déc. 2009 19:02

Heu... dans un sac en plastique ? Tu te trompes, c'est moi qui ais rapporté la carte à Fabrice, et je l'avais bien entourée dans une couverture pour ne pas qu'elle ne s'abime justement...

Je ne l'ai donc pas "explosée comme un vulgaire déchet" comme tu le dis... Je suis par contre désolé que tu l'ais récupérée en mauvais état, je ne l'ais pas regardée en détail lors de mon arrivée, mais elle ne me paraissait pas abîmée :(
Nico
Obsolete Tears - Musée Virtuel du Jeu Vidéo
Image
http://www.obsolete-tears.com

Avatar de l’utilisateur
Ythunder
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 3938
Inscription : 09 août 2008 17:46
Localisation : 03

Re: Dump de la rom IO_CPU

Message par Ythunder » 02 déc. 2009 19:23

Franchement jester je ne pense pas que le taf et l'intérêt que tu portes a ta machine soit inutile, surtout ici ! Si tu as eus une très mauvaise expérience là, laisses le temps au temps mais ne fou pas tt en l'air. Et moi, je ne passe pas aussi pour un uluberlu auprès des autres avec mon msx. Mes Thomson 8 couleurs qui bavent en320/200 et mes ST ?

Ce que tu fais a de l'intérêt ! Je ne dais guère fonctionner l'exel100 chez moi, mais comment tu expliques que j'ouvre ce post ?? Parce techniquement votre taf, le taf de Fabrice, torlus et les autres est super intéressant !

Donc réfléchis, je ne pense pas être le seul a ne pas souhaiter que tu disparaisse du forum.
Je suis CHARLIE
Tell me boy, do you have a room, in your heart, for the Computer boom...

Avatar de l’utilisateur
Fabrice Montupet
Administrateur
Administrateur
Messages : 10329
Inscription : 17 mai 2002 11:39
Localisation : Nevers - France

Re: Dump de la rom IO_CPU

Message par Fabrice Montupet » 02 déc. 2009 22:47

Décidément, l'ambiance n'est pas à la fête dans les forums ces derniers temps.

Voici un peu plus d'information après quoi, nous tournerons la page pour des choses plus heureuses.
J'ai écris à Jester dernièrement car il passait dans notre belle région de Bourgogne et projetais de récupérer son matériel Exelvision. Son clavier est réparé, j'ai trouvé les composants défectueux en mode filaire et il fonctionne très bien maintenant :)
Pour ce qui est de la carte mère. Je l'ai récupéré dernièrement chez Nico, elle était posée dans un sac plastique Game.fr à ce moment mais je ne doute en aucun cas qu'elle ai été entourée d'une couverture tout au long du transport entre Toulouse et Nevers. Le problème vient du fait que la carte mère d'EXL100 se trouve flanquée d'un énorme dissipateur thermique pour refroidir le LM7805. Ce dissipateur est maintenu à la carte mère par deux petits ergots peu efficaces ainsi qu'une vis au régulateur de tension. Quand les ergots ne tiennent pas, ce qui est assez courrant, c'est sur ce malheureux LM7805 que toute la charge du dissipateur repose. Et dans notre cas, à un moment donné, le dissipateur a fait une pression sur la carte mère en bougeant et, de fait, des broches se sont dessoudées à la base de la carte mère. Je confirme, le problème n'était pas très visible quand on y prête pas attention. Résultat: Sans tous ses voltages, la carte mère ne s'est pas initialisée à la mise sous tension. Après avoir vu le problème puis ressoudé le LM7805, j'ai constaté que le transfo d'alimentation (par nature fragile) ne fonctionnait plus. Après son remplacement par un transfo d'EXL100 en spare, la carte mère a démarré en affichant le beau papillon sur fond bleu! :) Mais j'ai constaté ensuite qu'en insérant une cartouche Exelbasic, elle n'était pas reconnue :( et en insérant une cartouche Imagix, le programme s'exécutait mais avec un fort garbage à l'écran :( Je ne peux en dire plus pour l'instant (quand, comment, où) car n'ayant pas eu le temps d'aller plus loin dans mes investigations. Je soupçonne de la DRAM défectueuse car très sujette à problèmes en cas de charges statiques et vieillit très mal... mais je ne suis encore sûr de rien. En tout cas, c'est réparable, j'en suis certain :)
Cela dit, ne perdons pas de vue que nous utilisons du matériel qui est normalement sensé ne plus être en circulation, sensé avoir été benné depuis des lustres. Ces machines n'ont pas été conçues pour tenir plus de 20 ans! et il n'est pas rare de devoir jouer du fer à souder, du swap de composants pour continuer à les faire fonctionner. D'ailleurs, je passe un temps très important à réparer, restaurer du matériel (UC et périphériques) Apple II, Lisa, TI-99 et Exelvision. Et quand le matériel est remis en état, il m'arrive d'avoir à le réviser à nouveau au bout de quelques années car d'autres composants ont fini par lâcher... C'est d'ailleurs un argument fort des créateurs d'émulateur qui permettent ainsi de pouvoir utiliser les logiciels de notre enfance quand nous ne pouvons pas/plus utiliser le micro ordinateur original. Pour ma part, je suis encore un grand fan de la machine, la vraie!! Mais cela a un prix: savoir accepter les pannes et accepter de consacrer de nombreuses heures à les restaurer.

Torlus
Administrateur
Administrateur
Messages : 1267
Inscription : 15 oct. 2005 22:33
Contact :

Re: Dump de la rom IO_CPU

Message par Torlus » 02 déc. 2009 23:36

Merci Fabrice pour ces précisions.
Pareil, je ne crois pas une seconde que Nico ait négligé la carte que je lui ai confié.

Quant à moi, j'ai parcouru le forum system-cfg pour essayer de comprendre le pourquoi du comment, et j'ai fini par y retrouver ces "cross-topics" concernant l'Exl100.
http://forum.system-cfg.com/viewtopic.php?f=15&t=1854
http://forum.system-cfg.com/viewtopic.p ... &start=120
C'est bien, on y trouve de tout, querelles d'égo, condescendance à peine voilée envers les "collectionneurs", et j'en passe. Pour ma part, j'ai bien apprécié la remarque sur le "bulldozer du fer à souder".
Bref, si ce que vous trouvez ici ne vous convient pas, la porte de sortie est grande ouverte.
"Pour finir, faut commencer."
"Il faut être un peu félé pour laisser passer la lumière".

Avatar de l’utilisateur
gilles
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 2742
Inscription : 17 avr. 2007 21:25
Localisation : 44
Contact :

Re: Dump de la rom IO_CPU

Message par gilles » 03 déc. 2009 00:07

humeur a écrit :
gilles a écrit :
jester a écrit :Je sens comme une odeur de crâmé... c'est pas mon 7041 qui est en train de bruler j'espère :lol:

L'avant dernière inconnue d'Exelvision va t'elle être levée ? Le suspens est insoutenable... plus dur encore qu'un épisode de "Plus belle la vie".

Après il reste à extraire la ROM du synthe vocal TM5220...
Et à trouver la doc du processeur video TMS3556, mais la on touche au mythe... à la légende urbaine.
faut relativiser... cette doc intéresse en tout et pour tout:
_ Toi,
_ Fabrice;
_ Daniel
et moi...
Ça fait un peu léger comme légende Urbaine...
et bien les autres auront le plaisir de vous laisser entre vous.

jl
hey, en fait c'est toi qui a commencé... je n'ai fait que copier ta méthode :)

jester
Fonctionne à 300 bauds
Fonctionne à 300 bauds
Messages : 263
Inscription : 29 déc. 2008 18:30

Re: Dump de la rom IO_CPU

Message par jester » 03 déc. 2009 00:15

Ne passe plus de temps sur cette carte Fabrice... j'étais surtout contrarié en pensant au temps passé par Torlus pour tout ressouder. Le matos Exelvision sera de toute manière encartonné.

Je suis triste que cette aventure se termine en eau de boudin. Mais ce n'était qu'un loisir passager, et quand un loisir prend trop de temps et est au final une source d'emmerdement... basta !
J'ai réfléchi un peu avant de me décider, je pensais encore continuer tranquille dans mon coin, mais finalement non... je n'ai plus aucune motivation, aucun plaisir et aucune envie de me prendre la tête.

Mais je suivrais en spectateur les nouveautés ici et ailleurs.

jester
Fonctionne à 300 bauds
Fonctionne à 300 bauds
Messages : 263
Inscription : 29 déc. 2008 18:30

Re: Dump de la rom IO_CPU

Message par jester » 03 déc. 2009 00:33

Torlus a écrit :Merci Fabrice pour ces précisions.
Pareil, je ne crois pas une seconde que Nico ait négligé la carte que je lui ai confié.

Quant à moi, j'ai parcouru le forum system-cfg pour essayer de comprendre le pourquoi du comment, et j'ai fini par y retrouver ces "cross-topics" concernant l'Exl100.
http://forum.system-cfg.com/viewtopic.php?f=15&t=1854
http://forum.system-cfg.com/viewtopic.p ... &start=120
C'est bien, on y trouve de tout, querelles d'égo, condescendance à peine voilée envers les "collectionneurs", et j'en passe. Pour ma part, j'ai bien apprécié la remarque sur le "bulldozer du fer à souder".
Bref, si ce que vous trouvez ici ne vous convient pas, la porte de sortie est grande ouverte.
:mrgreen: :mrgreen: :mrgreen: :mrgreen: :mrgreen: :mrgreen: :mrgreen: :mrgreen:

Avatar de l’utilisateur
pstriolo
Modérateur
Modérateur
Messages : 3421
Inscription : 22 mai 2002 07:05
Localisation : Dans ton cul... au fond à gauche

Re: Dump de la rom IO_CPU

Message par pstriolo » 03 déc. 2009 07:12

Torlus a écrit :Merci Fabrice pour ces précisions.
Pareil, je ne crois pas une seconde que Nico ait négligé la carte que je lui ai confié.

Quant à moi, j'ai parcouru le forum system-cfg pour essayer de comprendre le pourquoi du comment, et j'ai fini par y retrouver ces "cross-topics" concernant l'Exl100.
http://forum.system-cfg.com/viewtopic.php?f=15&t=1854
http://forum.system-cfg.com/viewtopic.p ... &start=120
C'est bien, on y trouve de tout, querelles d'égo, condescendance à peine voilée envers les "collectionneurs", et j'en passe. Pour ma part, j'ai bien apprécié la remarque sur le "bulldozer du fer à souder".
Bref, si ce que vous trouvez ici ne vous convient pas, la porte de sortie est grande ouverte.
Je pense mon cher torlus que tu vas pouvoir remettre au stock de silicium le magnifique exeltel que nous avons récupéré et que tu as commencé à canibaliser pour dumper les autres roms qui manquent à nos chers développeurs. A la lecture de ces posts, je pense que tu as d'autres choses bien plus passionnantes à réaliser tout au moins pour des gens qui savent apprécier les choses à leur juste valeur et qui ne font pas une fixation sur leur anus.

Philou
Tout près de la Garonne
Non loin des Pyrénées
Il existe une ville
Toulouse où je suis né
Toulouse et son équipe
Son stade des 7 deniers
Les toulousains arrivent
Ils vont tout remporter

Avatar de l’utilisateur
Ythunder
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 3938
Inscription : 09 août 2008 17:46
Localisation : 03

Re: Dump de la rom IO_CPU

Message par Ythunder » 03 déc. 2009 08:42

on en apprends des choses en inter forum..
Je suis CHARLIE
Tell me boy, do you have a room, in your heart, for the Computer boom...

Avatar de l’utilisateur
gilles
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 2742
Inscription : 17 avr. 2007 21:25
Localisation : 44
Contact :

Re: Dump de la rom IO_CPU

Message par gilles » 03 déc. 2009 10:45

Ythunder a écrit :on en apprends des choses en inter forum..
yep, j'y vais une fois tous les 6 mois... et je ne suis jamais déçu :roll: ...

jester
Fonctionne à 300 bauds
Fonctionne à 300 bauds
Messages : 263
Inscription : 29 déc. 2008 18:30

Re: Dump de la rom IO_CPU

Message par jester » 03 déc. 2009 12:05

pstriolo a écrit :
Torlus a écrit :
Je pense mon cher torlus que tu vas pouvoir remettre au stock de silicium le magnifique exeltel que nous avons récupéré et que tu as commencé à canibaliser pour dumper les autres roms qui manquent à nos chers développeurs. A la lecture de ces posts, je pense que tu as d'autres choses bien plus passionnantes à réaliser tout au moins pour des gens qui savent apprécier les choses à leur juste valeur et qui ne font pas une fixation sur leur anus.

Philou
:) :D :lol: :lol: :lol: :lol:

Avatar de l’utilisateur
Fabrice Montupet
Administrateur
Administrateur
Messages : 10329
Inscription : 17 mai 2002 11:39
Localisation : Nevers - France

Re: Dump de la rom IO_CPU

Message par Fabrice Montupet » 03 déc. 2009 14:12

Toutes les ROM d'Exeltel n'ont plus de secret à ce jour, elle ont toutes été dumpées.
En souhaitant qu'avec celles d'EXL100, ces ROM puissent aboutir à la diffusion de nombreux émulateurs pour le plaisir de toutes celles et ceux qui désirent découvrir ou redécouvrir les micro-ordinateurs d'Exelvision de façon logicielle, celui de Gilles, de l'équipe MESS, de Daniel et bien d'autres encore je l'espère.

Les prochaines ROM restant a venir sont celles du rarissime Exeltel II (la quintessence de la philosophie Exeltel !) et je ne manquerai pas de vous en faire part dès qu'elles seront réalisées.

Avatar de l’utilisateur
pstriolo
Modérateur
Modérateur
Messages : 3421
Inscription : 22 mai 2002 07:05
Localisation : Dans ton cul... au fond à gauche

Re: Dump de la rom IO_CPU

Message par pstriolo » 03 déc. 2009 15:00

Dans ce cas pourquoi vous avez demandé à Torlus de dumper le 7042 ?

Ou alors j'ai pas tout suivi.

Philou
Tout près de la Garonne
Non loin des Pyrénées
Il existe une ville
Toulouse où je suis né
Toulouse et son équipe
Son stade des 7 deniers
Les toulousains arrivent
Ils vont tout remporter

Avatar de l’utilisateur
gilles
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 2742
Inscription : 17 avr. 2007 21:25
Localisation : 44
Contact :

Re: Dump de la rom IO_CPU

Message par gilles » 03 déc. 2009 15:46

pstriolo a écrit :Dans ce cas pourquoi vous avez demandé à Torlus de dumper le 7042 ?

Ou alors j'ai pas tout suivi.

Philou
bonne question...
je l'ai écrit là le 27 juillet 2009 : http://forum.system-cfg.com/viewtopic.p ... 3&start=15
Après çà je lis sur system-cfg que je ne poste jamais sur des sujets techniques... :D ... même l'admin le dit...
Bon, si ca intéresse quelqu'un mon emu exl100 a un peu avancé, le core 7xxx de MESS est buggé... y'a pas plus chiant a debugger que le code d'un autre... surtout un truc d'un niveau aussi élevé...

jester
Fonctionne à 300 bauds
Fonctionne à 300 bauds
Messages : 263
Inscription : 29 déc. 2008 18:30

Re: Dump de la rom IO_CPU

Message par jester » 03 déc. 2009 16:27

On a désassemblé la ROM7040.
On a identifié une routine fantôme qui semblait pourvoir recopier en mémoire ce qui était reçu du 7042 pour le CRC
On a réussi à détourner l'appel CRC normal pour utiliser cette routine fantôme
On s'est battu (un peu) avec la routine K7 en VRAM avant de choisir la CRAM et on a dumpé le 7042
J'ai remercié gilles en passant pour avoir évoquer cette possibilité de DUMP
On a ensuite confirmée une hypothèse de départ pour extraire la ROM6100 en analysant la ROM du 7042 et affiné
On a a alerté Torlus de passer le dump hard du 7042 en priorité basse en attendant confirmation de l'extraction... (pas confirmé car le générateur de caractère est douteux...)
On a dumpé la ROM6100

L'objectif de départ était le dump de la ROM6100, Mais la doc technique Exelvision est totalement fausse à ce sujet... et l'analyse du 7040 a permis de tomber sur la faisabilité de l'extraction du 7042 par hasard.

Tous les détails et l'histoire au jour le jour en fonction des emplois du temps de chacun sont dans le post.
Bref on s'est regardé l'Anus (expression très à la mode chez vos modérateurs... je m'adapte au vocabulaire) pendant quelques jours et au final c'est gilles qui en est sorti le 7ieme jour...

Voila l'histoire vraie, sans romance.
Je vous fais la bise.

Répondre

Revenir vers « Exelvision »