Conseils pour la restauration d'un lot NASCOM 1

Une machine en panne, cassée ? Un mode de fonctionnement incompréhensible ? Exprimez-vous ici

Modérateur : Politburo

Répondre
Avatar de l’utilisateur
zpalm
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 2499
Inscription : 03 mai 2008 15:33
Localisation : Grenoble

Conseils pour la restauration d'un lot NASCOM 1

Message par zpalm » 03 janv. 2019 18:42

J’ai eu un mois de Décembre très chargé et je n’ai pas eu l’occasion de vous parler d’un lot spécial que j’ai reçu fin Novembre et pour lequel j’ai besoin des conseils avisés des experts de Silicium.

J’ai été contacté en novembre par un lecteur régulier du forum qui s’étant retrouvé en possession de plusieurs éléments de NASCOM 1 m’a contacté grâce à l’intérêt que j’ai manifesté ici pour cet ordinausaure, et pour me proposer de me donner l’ensemble, ce que j’ai accepté avec un grand plaisir 😊 . Merci encore à ce généreux donateur qui se reconnaîtra sûrement.

Pour démarrer la nouvelle année avec ce qui sera sans doute mon grand projet pour 2019, voici le donc le détail de ce que j’ai reçu pour le prix des frais d’envoi :
  • une carte NASCOM 1 avec rom NASBUG 1
  • une carte NASCOM 1 avec rom inconnue
  • un clavier nu
  • un deuxième clavier dans un boitier métallique
  • une carte buffer pour connexion de cartes d’extension
  • une carte mémoire 32K + 3K d’EPROM (Tiny BASIC + Super Tiny BASIC)
  • une carte mémoire 4Mhz/48K avec les composants non montés
  • et aussi, non photographié et découvert lors de la réception du colis, une carte Veroboard avec deux connecteurs Vero type 14-0998G pour réaliser un fond de panier NASBUS pour les cartes d’extension. Une agréable surprise car ces connecteurs obsolètes semblent totalement introuvables.

    Image Image Image Image Image Image Image

    Je n’ai pas reçu d’alimentation (elle ne faisait pas partie à l’origine du kit NASCOM ), et comme la carte a besoin de +5, +12, -5 et -12V, j’ai récupéré une vieille alim ATX fournissant du -5V (les nouvelles en sont dépourvues) et j’ai acheté un petit adaptateur pour connecter mes cartes mères:
    Image

    Les deux cartes mères ont l’air d’avoir subi différentes modifications que je vais documenter avant toute tentative de restauration.

    Mais avant de mettre sous tension la première de ces cartes je voudrai solliciter les experts de ce forum: comment aborder la restauration d’un tel ensemble ? Que faut-il faire ? Que faut-il surtout ne pas faire ?

Nikass
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 1251
Inscription : 12 nov. 2015 23:00
Localisation : trouducul du 31 et 34 aux lunes bleues

Re: Conseils pour la restauration d'un lot NASCOM 1

Message par Nikass » 03 janv. 2019 19:17

Salut ! ça commence bien pour une bonne année :-)

Bon... Je vais te dire un truc qui fait pas plaisir. Si t'as jamais touché à rien de ce genre, t'as pas le cul sorti des ronces surtout vu la quantité de bidouille et la probabilité de le faire revivre uniquement à distance avec les conseils du forum sont... quasi nulles. Désolé, mais c'est la stricte vérité d'une looooooongue expérience dans le domaine, de plus, ça dépend du matériel et des connaissances dont tu disposes, faut en dire un peu plus. Pièces de rechange itou. Franchement, si t'as pas au minimum un multimètre, un scope et une alim de labo, ça va pas le faire.

Commençons par le commencement. L'alim ATX, c'est l'archétype de la fausse bonne idée: je m'explique. Ce sont des alimentations puissantes et quoique relativement protégées, si ça se passe mal, tu auras de gros dégâts parce qu'elles vont balancer un wagon d'ampères avant de plier. Donc déjà, oublie ça pour le moment.

Tu as là-dessus un certain nombre de composants à problèmes, à commencer par les 4116. Peu de chances qu'elles soient toutes indemnes, elles vieillissent presque toutes mal. Ensuite, les 2708 (ce qui doit justifier quasiment uniquement le besoin des tensions multiples). Là, il faut impérativement les dumper pour commencer, parce que tu ne sais pas (surtout pour celles qui ont les étiquettes maison) quelles bidouilles de code sont dedans et probablement en relation avec les modifs hardware; ça peut emmener loin, c'était un classique du genre à l'époque. Faut savoir que les programmateurs d'EPROM classiques ne savent pas les gérer en général, ça nécessite du matériel adapté. Si elles sont encore lisibles... sinon, s'assurer qu'on peut les retrouver sur le Net mais il faudra alors être sûr que c'est compatible avec les modifs, tu vois ce que je veux dire, revenir à une configuration connue. Pour les dupliquer au besoin, il faut en avoir de rab en état de marche et ça court pas les rues; il peut être envisageable d'utiliser à la place de la 2716 pour mieux dormir la nuit mais c'est pas pin-compatible direct. C'est assez simple: tu ne peux pas risquer de les flinguer, celles-là, si elles sont encore bonnes. Et les blanches, elles sont plus vieilles que moi...

Tout est sur support on dirait, ça, c'est la bonne nouvelle. L'idéal, si tu as accès à un système qui le fait (bon nombre de programmateurs décents savent faire) c'est de passer au test tous les 74xx et s'assurer en même temps de l'état d'oxydation des pattes, bref, faire le maximum de tests unitaires possibles. Processeurs, PIO, etc, peuvent se tester par swap sur un système connu mais il faut encore en avoir un sous la main, ou utiliser directement des puces connues bonnes. Existe-t-il sur ces cartes de la logique type PROM/GAL... ? là aussi, les composants programmables sont la prunelle de tes yeux, tout le reste se remplace, ça, non, si tu n'as pas accès à la logique de programmation et au contenu. Donc, réunir le maximum de doc; il y a une BOM disponible ?

Bon, je te laisse mijoter un peu tout ça. Je ne veux pas noircir le tableau, ça se remet en route, ça, fais-moi confiance, mais c'est pas un truc de débutant et il faut quand même l'artillerie lourde ! Je vois aussi des sockets vides, d'ici que ça soit du vampirisage pour dépanner un autre machin... ce qui serait fameux, ça serait d'avoir son frère en état de marche, mais...

a+

Nikass
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 1251
Inscription : 12 nov. 2015 23:00
Localisation : trouducul du 31 et 34 aux lunes bleues

Re: Conseils pour la restauration d'un lot NASCOM 1

Message par Nikass » 03 janv. 2019 19:27

En parlant de ROM... une qui m'inquiète c'est la 2708 blanche fenêtre découverte, et rassure moi, c'est pas le reflet d'un flash d'appareil photo qu'on voit sur l'image ????? ..........

+

Avatar de l’utilisateur
zpalm
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 2499
Inscription : 03 mai 2008 15:33
Localisation : Grenoble

Re: Conseils pour la restauration d'un lot NASCOM 1

Message par zpalm » 04 janv. 2019 00:32

Merci Nikass pour ta réponse détaillée. J'ai un peu d'expérience sur le sujet (sinon je ne me lancerai pas dans cette restauration): j'ai commencé ma vie professionnelle en concevant et mettant au point des cartes z80 et 68000. J'ai un multimètre et un analyseur logique mais pas de scope, c'est sans doute l'occasion d'en justifier l'achat.
Nikass a écrit :
03 janv. 2019 19:17
Commençons par le commencement. L'alim ATX, c'est l'archétype de la fausse bonne idée: je m'explique. Ce sont des alimentations puissantes et quoique relativement protégées, si ça se passe mal, tu auras de gros dégâts parce qu'elles vont balancer un wagon d'ampères avant de plier. Donc déjà, oublie ça pour le moment.
Zut, moi qui pensais avoir trouvé une solution simple. Sinon tu me conseilles quoi comme alim +5V/+12V/-5V/-12V?
Nikass a écrit :
03 janv. 2019 19:17
Tu as là-dessus un certain nombre de composants à problèmes, à commencer par les 4116. Peu de chances qu'elles soient toutes indemnes, elles vieillissent presque toutes mal. Ensuite, les 2708 (ce qui doit justifier quasiment uniquement le besoin des tensions multiples). Là, il faut impérativement les dumper pour commencer, parce que tu ne sais pas (surtout pour celles qui ont les étiquettes maison) quelles bidouilles de code sont dedans et probablement en relation avec les modifs hardware; ça peut emmener loin, c'était un classique du genre à l'époque. Faut savoir que les programmateurs d'EPROM classiques ne savent pas les gérer en général, ça nécessite du matériel adapté.
Ça je m'en doutais. J'ai un bête programmeur Mini Pro TL866 qui ne supporte pas les 2708. A priori les images sont déjà disponibles sur le Web mais je vais me pencher sur le dump de celles que j'ai. Pour les 4116 je pense qu'il va falloir prévoir des pièces de rechange, mais elles ne sont utilisées que sur les cartes d'extension, sur la carte mère ce sont des 2102, des RAM statiques 1024 x 1 (le design du Nascom 1 date de 1977).

Nikass a écrit :
03 janv. 2019 19:17
Tout est sur support on dirait, ça, c'est la bonne nouvelle. L'idéal, si tu as accès à un système qui le fait (bon nombre de programmateurs décents savent faire) c'est de passer au test tous les 74xx et s'assurer en même temps de l'état d'oxydation des pattes, bref, faire le maximum de tests unitaires possibles.
Oui, tout est sur support. A priori mon Mini Pro fait testeur de composants, il faut que je regarde exactement ce qu'il supporte.
Nikass a écrit :
03 janv. 2019 19:17
Existe-t-il sur ces cartes de la logique type PROM/GAL... ?
Pas de logique programmable.
Nikass a écrit :
03 janv. 2019 19:17
Donc, réunir le maximum de doc; il y a une BOM disponible ?
Oui, la doc ça va. J'ai monté un NASCOM 1 quand j'étais en terminale. Ensuite entre mes études et le déménagement de mes parents le NASCOM a disparu. J'ai retrouvé les manuels hardware et software il y a quelques années et comme je ne pensais pas retrouver un NASCOM je les ai envoyés à Pocket pour les archives de Silicium, mais avant je les ai numérisés, donc j'ai le schéma, la liste des composants et le source du moniteur.
Il y a aussi le site UK de référence: The Nascom Home Page.
Nikass a écrit :
03 janv. 2019 19:27
En parlant de ROM... une qui m'inquiète c'est la 2708 blanche fenêtre découverte, et rassure moi, c'est pas le reflet d'un flash d'appareil photo qu'on voit sur l'image ????? ..........
La photo a été prise par le généreux donataire et il est bien possible qu'il s'agisse d'un flash...

Encore merci pour tes conseils.

Nikass
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 1251
Inscription : 12 nov. 2015 23:00
Localisation : trouducul du 31 et 34 aux lunes bleues

Re: Conseils pour la restauration d'un lot NASCOM 1

Message par Nikass » 04 janv. 2019 09:21

Ben y'a pas de quoi ! Ta demande initiale me laissait penser que tu n'avais jamait fait, ça m'inquiétait un peu, parce que t'as pour ainsi dire qu'une chance :mrgreen: mais t'en n'es pas au coup d'essai...

Pour l'alim, il y a plusieurs approches. Par contre, quelle que soit la méthode, il y a un truc impératif: prévoir un arrêt d'urgence quelconque, bien en vue, si ça part en live et qu'il te faut fouiller sous le tas de filasse pour couper le jus, c'est dommage pour les cartes.

1) Tu peux très bien te trouver un petit bloc à découpage qui fait ça, mais de capacité plus limitée (de toute manière, on va parler de quelques ampères sur le +5 et quelques dizaines de milliampères sur les autres, j'imagine), ça évitera surtout le coup classique du composant en C/C mais un peu résistif quand même, qui va laisser passer assez de courant pour tout exploser mais pas assez pour que l'alim ATX soit au bout. Ca peut vite se chiffrer à une vingtaine d'ampères, si tu vois ce que je veux dire. Je suis pas fan de la méthode, tout rallumer d'un coup, beurk... En fait tu vas souvent trouver 5, +12, -12 en blocs industriels classiques; faut se rajouter un 7905, quoi.

2) Plus futé, essayer de comprendre à quoi servent les tensions multiples. 5, 12, et -5, c'est le trio pour 2708. Il est possible que le -12 soit utilisé pour de la communication série, s'il y en a quelque part (ou analogique ? vidéo... ?)... mais si j'avais à parier, je dirais qu'on peut faire tourner tout le bastringue en 5V si on roule avec des EPROM monotension quitte à ce qu'il manque une fonction. Comme définitivement, au début, je ne me risquerais pas les 2708, ça peut être une astuce intéressante, sans compter le fait qu'on ne sait toujours pas comment elles vont être, ces vieilles mémères, faudra bien au moins que tu vérifies leur contenu si tu as au moins un bout de référence et à ce tarif là recramer des 2716 et les adapter c'est plus le bout du monde (http://www.radiocollection.be/fr/Eprom2708_fr.html). Donc là, ben c'est facile; alim de labo limitée en courant, démarrer doucement, voir comment ça se passe, etc.

Une fois quelques résultats préliminaires obtenus, il sera toujours temps de retester les autres lignes d'alim avant d'y aller gaiment pour tout le monde. Piège: un circuit de RESET qui aurait un moniteur sur les 4 rails, m'enfin, à l'époque...

Tu connais l'astuce de l'autotest du z80 (in situ), le NOP câblé, je pense ?

La question pour le flash, je ne sais pas si tu as entendu parler de ça, mais ça flippe très bien un bit dans une EPROM à UV, y'en a qui ont eu des problèmes... bon, trop tard de toute manière, mais EPROM suspecte.

a+

Nikass
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 1251
Inscription : 12 nov. 2015 23:00
Localisation : trouducul du 31 et 34 aux lunes bleues

Re: Conseils pour la restauration d'un lot NASCOM 1

Message par Nikass » 04 janv. 2019 09:51

Bon, j'ai pas pu m'en empêcher, j'ai descendu le schéma... connaissais pas cette machine, une de plus :lol:

C'est bien ce que je pensais, le coup du +5 unique est largement gérable. Y'a que le sur le 6576 qui doit contenir une EPROM du même tonneau que ça peut être tendu, après, y'a peut être pas besoin de démarrer avec...

Trucs déjà vus dans le passé:

les transceivers de bus (81LS97, remplacement 74LS797) et pas que ceux là d'ailleurs, les 8T sur les apple, et d'autres. Sais pas pourquoi, mais fragiles.
les 2102 vu une panne sur un CBM une fois

le reste, bon, c'est du tout venant (je pensais à un truc en voyant l'UART, bon, moi j'ai pour règle de démarrer avec le minimum mais des fois c'est piègeux avec les composants à registres si le code principal fait une init, la teste, et tourne en rond).

ça va être intéressant de savoir ce que sont les bidouilles :slime: :slime: :slime:

a+

Avatar de l’utilisateur
zpalm
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 2499
Inscription : 03 mai 2008 15:33
Localisation : Grenoble

Re: Conseils pour la restauration d'un lot NASCOM 1

Message par zpalm » 05 janv. 2019 08:11

J'ai aussi vérifié les schémas et en dehors du +12/-12V utilisé pour les signaux RS232, les seuls composants utilisant du +12V et du -5V sont les 2708 et le générateur de caractères MCM6576.

Le plan d'attaque des cartes mères se précise: documenter les modifs, tester unitairement tous les 74xx, vérifier l'oxydation des contacts, préparer une 2716 pour remplacer la 2708 (avec le brochage adéquat), récupérer une alim de labo puis faire un démarrage progressif et contrôlé. On doit pouvoir valider pas mal de choses avec l'analyseur logique avant d'avoir besoin du générateur de caractères pour l'affichage sur l'écran.

En parallèle préparer les moyens de faire le dump des 2708 (merci pour le lien).
Nikass a écrit :
04 janv. 2019 09:21
Tu connais l'astuce de l'autotest du z80 (in situ), le NOP câblé, je pense ?
Merci je l'avais oublié :)
J'ai retrouvé la description ici et entre autres.

Nikass
Fonctionne à 2400 bauds
Fonctionne à 2400 bauds
Messages : 1251
Inscription : 12 nov. 2015 23:00
Localisation : trouducul du 31 et 34 aux lunes bleues

Re: Conseils pour la restauration d'un lot NASCOM 1

Message par Nikass » 05 janv. 2019 10:10

ça a quand même plus de gueule comme plan que d'y foutre dix litres d'essence et une allumette :lol: :lol: :lol:

bon, ben on attend la suite avec impatience... si t'as des bricoles à chercher ou à commander, tu peux te procurer quelques pinces à circuits intégrés, le nombre de fois où je me suis fait peur avec des pointes de touche qui glissent, je ne joue plus

Image

bon week end !

Marcopolo
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 426
Inscription : 22 sept. 2010 16:18
Localisation : Nancy

Re: Conseils pour la restauration d'un lot NASCOM 1

Message par Marcopolo » 24 janv. 2019 21:33

Je peux dumper/fournir/programmer des 2708 si besoin.
Dernière édition par Marcopolo le 25 janv. 2019 09:53, édité 1 fois.
http://www.retronik.fr La documentation de l'électronique française
http://marc.retronik.fr Mes Annonces & Recherches

Avatar de l’utilisateur
rene
El Presidente
El Presidente
Messages : 1235
Inscription : 16 mai 2002 20:08
Localisation : Toulouse
Contact :

Re: Conseils pour la restauration d'un lot NASCOM 1

Message par rene » 25 janv. 2019 09:35

Si besoin, on a retrouvé notre Nascom au grand complet.
René

Répondre

Revenir vers « Problèmes techniques »