Commodore SX64 et lecteur disquettes

Une machine en panne, cassée ? Un mode de fonctionnement incompréhensible ? Exprimez-vous ici

Modérateur : Politburo

Répondre
grandjojo
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 4
Inscription : 08 mai 2018 12:58

Commodore SX64 et lecteur disquettes

Message par grandjojo » 16 oct. 2018 18:50

Bonjour a tous,

j'ai récupérer un commodore sx64 qui présente 2 petits problèmes.

Le plus urgent est le lecteur de disquette qui apparemment fonctionne , puisque il tourne quelque secondes au démarrage de l'ordinateur puis lorsque j'introduit la commande ( load"$",8 ) l'ordinateur affiche qu'il recherche $ mais rien ne bouge dans le lecteur !!!!

J'ai même brancher un lecteur externe mais il ne répond pas non plus !

je suis vraiment triste de posséder une si belle machine et de ne pas pouvoir l'utiliser .

Et pour le 2é problème , il s'agit d'une touche du clavier qui n'est plus " fixer " et donc la touche n'est plus utilisable , je vous envoi des photos le plus rapidement possible .

Mais ma priorité reste le lecteur !!

Je suis bien évidement a l'écoute de vos idée et de vos demande si nécessaire .

D'avance un grand merci et bonne soirée.

Avatar de l’utilisateur
snsv6502
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 19
Inscription : 12 oct. 2018 21:23
Localisation : Nantes

Re: Commodore SX64 et lecteur disquettes

Message par snsv6502 » 16 oct. 2018 19:35

Salut,
Je ne connais pas le sx64, mais si c'est la même chose qu'un c64 + un 1541 (donc si le lecteur de disquette est 'autonome' comme un 1541, avec son 6502, ses deux 6522 etc..) le plus simple reste de vérifier si le 'reset' du drive à l'allumage est bon. Machine éteinte, si tu déplaces à la main la tête de lecture vers le track 35 (pas trop loin quand même) et que tu allumes ensuite la machine, la tête de lecture devrait bouger pour revenir vers le track 18.
Si c'est ce qui se passe, ça veut dire que ton 6502 fonctionne et que la rom semble bonne puisque le lecteur a exécuté le code qui recalibre la tête. Dans ce cas, il faudrait chercher du côté de la liaison série entre le c64 et le lecteur de disquette. S'assurer que le défaut ne vient pas du c64 (qui peut déconner) puis si c'est bon, trouver le schéma du drive et remonter le port série pour voir ce qui pourrait éventuellement déconner.
Y'a peut-être plus malin à faire mais c'est plus ou moins ce que je tenterais si j'avais à aborder le problème.
:roll:
J'ai en pdf un bouquin dédié à la recherche de pannes des 1541, avec des procédures (y'a pas la mienne, elle doit être trop naze :mrgreen: ) en arborescence, si ça t'intéresse...

Cela dit, si ce n'est pas une sorte de 1541 qui se trouve dans le sx64, ça ne servira à rien :?
]CALL-151
*

Avatar de l’utilisateur
bernouilli92
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 2658
Inscription : 21 nov. 2012 14:03
Localisation : Ile de France

Re: Commodore SX64 et lecteur disquettes

Message par bernouilli92 » 16 oct. 2018 19:43

C'est bien un 1541 qui est dans le sx64.
Si tu veux brancher un lecteur externe, il faut que celui-ci ait un autre identifiant que 8, ou alors que le lecteur interne ait in autre identifiant que ou ou qu'il soit débranché.
Débranche le lecteur interne et teste avec un lecteur externe puisque tu en as un.
Ensuite les recherches de pannes sur 1541 sont assez complexes et il vaut mieux y aller par étapes et s'aider d'un document t qui décrits les différentes pannes et symptômes.
Le test donné par snsv6502 est un bon début.
Dernière édition par bernouilli92 le 16 oct. 2018 22:08, édité 1 fois.
HP, Casio, Sharp, Psion, quelques TI et divers autres

grandjojo
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 4
Inscription : 08 mai 2018 12:58

Re: Commodore SX64 et lecteur disquettes

Message par grandjojo » 16 oct. 2018 20:40

Bonsoir snsv6502

Merci pour ta réponse .
J ai effectués le petit test et en effet le chariot ne revient pas en place . j'en déduit donc que le 6502 fait défaut !?

J ai un lecteur externe que j ai démonter pour en prélevé la puce mais elle est soudée !!!

Avant de passé au désoudage je voulait te demandé ton avis !

Avatar de l’utilisateur
snsv6502
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 19
Inscription : 12 oct. 2018 21:23
Localisation : Nantes

Re: Commodore SX64 et lecteur disquettes

Message par snsv6502 » 16 oct. 2018 21:14

Euh non, ça n'est pas le forcément le 6502... ça peut être n'importe quoi d'autre (RAM / ROM / 74LS04 / n'importe quoi d'autre), mais au moins tu sais que le lecteur a un défaut.
On peut poser des tonnes de questions et l'on n'en finirait pas, ex : Est-ce que la broche reset du 6502 passe à environ 5v ? si ça n'est pas le cas, c'est que le 6502 ne se 'réveille' jamais vu qu'il n'a pas la bonne tension sur cette broche, du coup faudrait trouver pourquoi etc...
Le défaut peut provenir d'un peu n'importe quoi, il va falloir investiguer... en commençant par l'analyse du comportement du lecteur quand on l'allume.
:roll:
Je te conseille de récupérer le bouquin avec le lien que je t'ai envoyé par MP et de commencer en suivant les procédures qui permettent d'identifier les problèmes.
Bon courage.
:wink:

ps : les Chinois vendent des 6502 à quelques centimes la pièce... inutile de vampiriser du matos pour ça, surtout sans avoir clairement identifié la panne au préalable :mrgreen: .
]CALL-151
*

Avatar de l’utilisateur
jvernet
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7527
Inscription : 24 mai 2002 09:57
Localisation : France 69
Contact :

Re: Commodore SX64 et lecteur disquettes

Message par jvernet » 16 oct. 2018 21:41

Déja, verifier que la mécanique fonctionne bien, lecteur nettoyé, graissé si besoin. Ca doit coulisser facilement.
"l'ordinateur et l'homme sont les deux opposés les plus intégraux qui existent. L'homme est lent, peu rigoureux et très intuitif. L'ordinateur est super rapide, très rigoureux et complètement con."

grandjojo
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 4
Inscription : 08 mai 2018 12:58

Re: Commodore SX64 et lecteur disquettes

Message par grandjojo » 16 oct. 2018 22:00

J'ai finalement vampirisé un 6502 , mais malheureusement toujours les même symptômes :(

Se que je ne comprend pas c'est pourquoi il ne reconnaît pas le lecteur externe ?

Avatar de l’utilisateur
bernouilli92
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 2658
Inscription : 21 nov. 2012 14:03
Localisation : Ile de France

Re: Commodore SX64 et lecteur disquettes

Message par bernouilli92 » 16 oct. 2018 22:07

Parce que le lecteur externe a le même numéro de device. Le fameu 8 dans load"*",8
Soit tu changes le numéro de device du lecteur externe (jumpers à couper ou souder), soit tu changes le numéro de device du lecteur interne. Soit tu débranches le lecteur interne (courant ou connexion serial).
Mais je crois que je me répète.
HP, Casio, Sharp, Psion, quelques TI et divers autres

grandjojo
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 4
Inscription : 08 mai 2018 12:58

Re: Commodore SX64 et lecteur disquettes

Message par grandjojo » 16 oct. 2018 23:07

Oui bien sur !

Je viens de tester en changeant les switches sur lecteur externe et déconnecter le lecteur interne ...

Mais toujours rien :( :( :(

demain je test le lecteur externe sur un commodore 64 classique pour vérifier si il fonctionne !

Merci a snsv6502 pour ton PDF , mais avec mon niveau d' anglais je ne suis pas très avancée :D :D :D

Mais je ne me décourage pas .

Avatar de l’utilisateur
SbM
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 4372
Inscription : 24 nov. 2004 22:49
Localisation : SQY (78), France
Contact :

Re: Commodore SX64 et lecteur disquettes

Message par SbM » 17 oct. 2018 00:57

Ça pourrait pas venir d'un chip défaillant dans le SX64, genre un CIA ?
http://sbm.ordinotheque.free.fr | http://www.mo5.com
"Un bon disque dur est un disque dur mort." (Général Cluster)

Avatar de l’utilisateur
snsv6502
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 19
Inscription : 12 oct. 2018 21:23
Localisation : Nantes

Re: Commodore SX64 et lecteur disquettes

Message par snsv6502 » 17 oct. 2018 06:41

Oui, ça pourrait, mais en tapant au hasard et sans méthode, on en a pour six mois si jamais on trouve quoique ce soit. J'ai bien peur qu'il soit largement préférable d'amener la machine à quelqu'un versé dans la réparation de ce genre de matériel.
:ugeek:
]CALL-151
*

Répondre

Revenir vers « Problèmes techniques »