Display Turbo LED sur Zida 4DPS Tomato

Une machine en panne, cassée ? Un mode de fonctionnement incompréhensible ? Exprimez-vous ici

Modérateur : Politburo

Répondre
peperocket
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 18
Inscription : 04 sept. 2017 12:59

Display Turbo LED sur Zida 4DPS Tomato

Message par peperocket » 13 sept. 2017 20:45

Salut !

J'ai un 486 dx2 qui fonctionne correctement avec un affichage turbo que je n'ai pas réussis à faire fonctionner.

Au passage la carte mère a quand même un bug passé l'année 2000, mais bon vu la galère pour mettre à jour le bios, on fait avec.

J'ai trouvé le site suivant qui pourrait aider : http://www.minuszerodegrees.net/led_spe ... isplay.htm

Je vais regarder ça ce soir, j’espère avoir plus de résultat qu'avec ce satané PS/1 :-)

Si quelqu'un possède cette carte ou à une expérience dans le domaine, tout conseil est bon à prendre ;-)

Nikass
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 685
Inscription : 12 nov. 2015 23:00
Localisation : 34 et trouducul du 31

Re: Display Turbo LED sur Zida 4DPS Tomato

Message par Nikass » 13 sept. 2017 21:21

Ahah ! Si tu laisses tomber encore plus vite que le PS/1, ça va être dur :twisted:

Les Turbo de l'époque... qui sont en fait des demi-vitesses, hein... y'a deux aspects: le truc qui dit à la CM dans quel mode se mettre, et un machin en façade qui est commandé uniquement par le switch, et pas par la CM, qui raconte du flan sur un afficheur à LED. Y'avait des variantes à switch deux positions, ou reprise sur le petit PCB, enfin.... comme d'hab... ou renvoi vers la LED turbo qui se tranformait en pseudo affichage...

C'est expliqué, pas toujours clair, dans ton lien...

Bon, si tu nous disais d'abord ce qui ne va pas ?

a+

peperocket
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 18
Inscription : 04 sept. 2017 12:59

Re: Display Turbo LED sur Zida 4DPS Tomato

Message par peperocket » 13 sept. 2017 22:09

Salut Nikass!

Le problème du PS/1 c'est que c'est la carte vidéo ou l'écran, dans les deux cas, je n'ai malheureusement pas les compétences pour réparer ça ...

Ici, j'ai fais un PC à partir d'un boitier vide. N'ayant pas les infos sur cet afficheur LCD quand je l'ai fait, je n'ai pu le faire fonctionner.

Cependant, tous les autres boutons, leds fonctionnent. Je vais déjà tenter d'identifier cet afficheur, si il fait parti de ceux référencés dans le lien, on commencera plutôt bien ...

peperocket
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 18
Inscription : 04 sept. 2017 12:59

Re: Display Turbo LED sur Zida 4DPS Tomato

Message par peperocket » 13 sept. 2017 23:54

Bon finalement c'est un S-305 à 2 digits : http://www.minuszerodegrees.net/led_spe ... S-305H.jpg

Mon CPU est un Intel 486DX2 à 66Mhz.

J'ai compris dans le manuel de la carte mère qu'en fait il est en 33Mhz en mode normal et 66 en mode turbo, dites mois si je me trompe ...

Voici le manuel de la carte mère : https://www.rom.by/files/4dps0210.pdf

Du coup il est bien raccordé au niveau du switch turbo, par contre je n'avais pas raccordé de 5V :oops: .

Avatar de l’utilisateur
Fabrice Montupet
Administrateur
Administrateur
Messages : 11328
Inscription : 17 mai 2002 11:39
Localisation : Nevers - France

Re: Display Turbo LED sur Zida 4DPS Tomato

Message par Fabrice Montupet » 14 sept. 2017 00:46

peperocket a écrit :
13 sept. 2017 23:54
Mon CPU est un Intel 486DX2 à 66Mhz.
J'ai compris dans le manuel de la carte mère qu'en fait il est en 33Mhz en mode normal et 66 en mode turbo, dites mois si je me trompe ...
Tu te trompes, mais c'est normal. Ce mode "turbo" était une désignation purement marketing bien entretenue à l'époque par les constructeurs et commerciaux car très vendeur. Ce mode est en fait le mode normal où le micro-processeur fonctionne à sa vitesse de conception (ici 66 Mhz) . La carte mère dispose donc d'un mode "lent" qui sous cadence le micro-processeur ( ici à 33 MHz) pour faire fonctionner correctement certains programmes conçus pour des PC plus anciens qui, exécutés à pleine vitesse seraient inutilisables. Principalement les jeux, mais pas qu'eux.
Deux autres exemples: Les PC à base de 8088 à 8MHz que l'on pouvait ralentir à 4.77MHz. Ils n'étaient pas des 8088 à 4.77MHz avec un mode turbo à 8 MHz. Idem pour des PC à base de 80286 à 12 ou 16 MHz que l'on pouvait brider à 8 MHz.

Le 486DX2 66 est un CPU dont la fréquence interne de fonctionnement est de 66MHZ (ou de 33 MHz si on le bride) et qui s'installe sur une carte mère dont le bus est cadencé à 33MHz.

peperocket
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 18
Inscription : 04 sept. 2017 12:59

Re: Display Turbo LED sur Zida 4DPS Tomato

Message par peperocket » 14 sept. 2017 06:28

Ca veut dire que sans ce "turbo" activé, le processeur est bridé à 33Mhz?

Nikass
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 685
Inscription : 12 nov. 2015 23:00
Localisation : 34 et trouducul du 31

Re: Display Turbo LED sur Zida 4DPS Tomato

Message par Nikass » 14 sept. 2017 06:44

Ben oui, c'est ce que j'appelais demi-vitesse :mrgreen:

Quelles vaches, ces marchands de tapis :lol:

a+

peperocket
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 18
Inscription : 04 sept. 2017 12:59

Re: Display Turbo LED sur Zida 4DPS Tomato

Message par peperocket » 14 sept. 2017 08:15

Ok merci à tous pour ces explications.

En effet le turbo était tendance, ne serait-ce que sur les voitures, quelle époque ...

Je pense récupérer le Grd et le 5V sur le port IR de la carte mère qui n'est pas utilisé depuis que je l'ai déjà pris sur le lecteur cdrom pour le ventilo CPU.

Est ce une mauvaise idée?

peperocket
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 18
Inscription : 04 sept. 2017 12:59

Re: Display Turbo LED sur Zida 4DPS Tomato

Message par peperocket » 14 sept. 2017 14:04

Finalement j'ai opté pour le 5V du haut parleur.

C'est bon ça marche nickel!

Image

Répondre

Revenir vers « Problèmes techniques »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 7 invités