Probleme carte Le Chat Mauve

Apple 1, ][, //, IIGS ou /// et 4

Modérateur : Politburo

Avatar de l’utilisateur
jvernet
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7714
Inscription : 24 mai 2002 09:57
Localisation : France 69
Contact :

Re: Probleme carte Le Chat Mauve

Message par jvernet » 22 mars 2019 22:27

Un peu de lecture pour commencer, su rle mixed mode:

http://boutillon.free.fr/Underground/An ... oaded.html

http://boutillon.free.fr/Underground/An ... ml#EXTASIE

Entre la carte Apple RVB et la carte EVE, si le resultat est le même, la manière de l'activer diffère un peu suivant les 2 cartes:

Code : Tout sélectionner

FWIW, the "old" A2D code hits switches in this order:

CLR80VID, AN3_OFF, AN3_ON, AN3_OFF, AN3_ON, SET80VID, AN3_OFF, DHIRESON, SET80VID, HIRES, PAGE1, MIXCLR, TXTCLR

My "new" A2D code hits them in this order:

DHIRESON, SET80VID, HIRES, PAGE1, MIXCLR, TXTCLR, CLR80VID, AN3_OFF, AN3_ON, AN3_OFF, AN3_ON, SET80VID, AN3_OFF
"l'ordinateur et l'homme sont les deux opposés les plus intégraux qui existent. L'homme est lent, peu rigoureux et très intuitif. L'ordinateur est super rapide, très rigoureux et complètement con."

nicolho
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 33
Inscription : 14 sept. 2018 02:06

Re: Probleme carte Le Chat Mauve

Message par nicolho » 22 mars 2019 23:10

Bien au contraire Nikass, il suffit de relire pour voir que j'avais bien précisé que j'encourageais d'abord les possesseurs de ces cartes à tenter de le faire eux-même si intéressés.
Et dans le genre "pas très sympa", se voir répondre des "ben, heu...", "hein", "c'est pas le sujet", agrémenté du smiley :roll: , et autres remarques du genre "moi aussi j'ai les moyens et les connaissances, si je veux", "on est pas tombé de la dernière pluie", "pas compliqué: t'as qu'à t'en acheter une toi-même et faire ça tout seul", c'est un peu l’hôpital qui se fout de la charité, mais bon... pour le dernier point (bien que ça contraste étonnamment avec tes généreuses et fréquentes propositions de matériel Apple II, y compris faites de but en blanc à des nouveaux venus) évidemment je n'y avais pas pensé, je dois être un "gonze pas du coin" tombé de la dernière pluie :tongue:

Jvernet, merci d'avoir finalement donné ton sentiment sur cette proposition. Pour la carte Féline, c'est surtout parce que ça me paraissait plus simple et dans mes cordes (la LCM-1 a moins de pattes) et que je crois avoir déjà une bonne idée de la logique contenue. De plus, le nombre restreint de composants simplifierait la création d'un clone.

Mais pour le côté "tout soudé", je te comprends, ça me refroidirait aussi (comme l'achat/revente, qui n'est pas trop mon truc, contrairement à la plupart des collectionneurs qui fréquentent le forum). Par contre, ça me surprend parce que sur les photos de la carte Féline de différentes sources, j'ai toujours vu les puces sur des supports bleus, par exemple là : https://mirrors.apple2.org.za/Apple%20I ... 0Front.jpg
Pour le reste, en étant précautionneux et méthodique, il y a moyen d'analyser la puce sans risquer de la brancher n'importe comment (même si on est jamais à l’abri d'un souci :mrgreen: ) . Enfin c'est une responsabilité, d'autres se proposeront peut-être de le faire avec leur propre matos, parce que pour l'instant, ma motivation vient d'en prendre un petit coup... a+

Nikass
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 1147
Inscription : 12 nov. 2015 23:00
Localisation : trouducul du 31 et 34 aux lunes bleues

Re: Probleme carte Le Chat Mauve

Message par Nikass » 22 mars 2019 23:42

Ben on s'est pas compris, point. C'est pas grave ! C'est juste que des fois, purée, si tu savais ce qu'on entend...

J'avoue que j'ai un peu de mal à comprendre ce que tu veux dire avec "tes généreuses et fréquentes propositions de matériel Apple II, y compris faites de but en blanc à des nouveaux venus", mais bon, je m'en fous, tu connais pas le bonhomme, je vais pas t'en vouloir. J'en ai dépanné assez pour ne pas me prendre le chou avec ça, c'est la manière qui l'a pas fait, je ne sais pas, j'suis un peu soupe au lait des fois mais je connais plein de gens qu'ont pas à se plaindre de mon tas de bordel :-)

Bon. Il te faut donc une Féline avec supports. Sais même pas si j'en ai une de rab facile d'accès... en revanche je joue le jeu, si tu trouves une toute soudée je m'engage à te la remonter sur supports si le jeu du fer à souder ne te plaît pas; et à te l'instrumenter selon tes consignes pour que tu puisses brancher le matériel d'analyse de ton choix. Je ne peux pas faire mieux, sinon après, c'est moi qui vais sortir le tableau de Karnaugh de la 82S100 et comme je te le disais, je m'en contrefiche, j'ai plus envie de rajouter un 25896e trophée de reverse à mon tableau de chasse !

deal ?

a+

Avatar de l’utilisateur
jvernet
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7714
Inscription : 24 mai 2002 09:57
Localisation : France 69
Contact :

Re: Probleme carte Le Chat Mauve

Message par jvernet » 22 mars 2019 23:49

Je suis totalement incompetent pour imaginer juste comprendre à quoi sert une puce, donc je suis incapable de "faire moi même".

Je vais appaiser un peu les choses: je n'ai pas réagi à la proposition de Nicolho, parceque j'allais réfléchir et réagir ultérieurement, en fonction de la possibilité que je retrouve ces cartes.

Il a fallu que je range ces putains de cartes y'a 3 semaines, quand j'ai refais mon bureau.... Maintenant, elles sont dans un carton, lui même dans un autre carton, dans 30m3 de cartons qui constituent ma collection....
bureau.jpg
bureau.jpg (50.17 Kio) Consulté 1138 fois
C'est le problème d'un bureau rangé: on retrouve plus rien...



C'est marrant, j'ai pas en mémoire que la Feline est sur supports, et qu'il y a sur la mienne un gros composant. Ma mémoire me joue des tours.
"l'ordinateur et l'homme sont les deux opposés les plus intégraux qui existent. L'homme est lent, peu rigoureux et très intuitif. L'ordinateur est super rapide, très rigoureux et complètement con."

Nikass
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 1147
Inscription : 12 nov. 2015 23:00
Localisation : trouducul du 31 et 34 aux lunes bleues

Re: Probleme carte Le Chat Mauve

Message par Nikass » 22 mars 2019 23:57

Eh ben tu vois, piqué au vif, j'suis allé fouiller, résultat une Féline sur supports bleus, avec c'te magnifique LCM-1 qui n'attend que son dépiautage :-)

problème de nicolho résolu, dès qu'il m'enverra son adresse en MP. Y'a pas gras de boulot pour refaire le schéma, en tout cas. On pourrait se le partager, je refais le schéma, et tu fais la logique ?

Pour ton histoire, je m'en occupe; j'attends le matériel de gpe que tu voulais et qui va transiter par chez moi. Faudrait que tu me dises exactement ce que je dois reproduire comme test pour être sûr que je t'envoie bien une référence, qu'on sache où on campe.

a+

Avatar de l’utilisateur
jvernet
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7714
Inscription : 24 mai 2002 09:57
Localisation : France 69
Contact :

Re: Probleme carte Le Chat Mauve

Message par jvernet » 23 mars 2019 00:00

eh ben voila, amis ;).

Après, un petit batch de production chinoise, et voila !

<cela dit, la feline est moins bien que la eve.
"l'ordinateur et l'homme sont les deux opposés les plus intégraux qui existent. L'homme est lent, peu rigoureux et très intuitif. L'ordinateur est super rapide, très rigoureux et complètement con."

Nikass
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 1147
Inscription : 12 nov. 2015 23:00
Localisation : trouducul du 31 et 34 aux lunes bleues

Re: Probleme carte Le Chat Mauve

Message par Nikass » 23 mars 2019 00:10

vi !

c'est pas la même chose, quoi. Tu peux me faire le topo de ce qui déconne chez toi, que je m'assure que je ne suis pas dans la même situation ? je sais que tu l'as expliqué en gros, mais si on se met d'accord sur une procédure simple... merci !

(une copie de Eve, je suis quasi sûr que ça existe, j'en ai vu passer une, ou un truc qui y ressemble. Me demande même si c'est pas le paternel qui se l'était soudée, faut que je cherche mais ça sera facile, c'est dans la machine historique que je conserve pieusement). De là à avoir les schémas et tout... c'est pas impossible non plus, mais où, dans le tas de papier...

a+

Avatar de l’utilisateur
jvernet
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7714
Inscription : 24 mai 2002 09:57
Localisation : France 69
Contact :

Re: Probleme carte Le Chat Mauve

Message par jvernet » 23 mars 2019 09:23

Pour voir si ca marche, lance DazzleDraw 1.2, ou Extasie.
Les menus doivent apparaître en blanc, chez moi ca apparait dans un goubiboulga de couleurs infames, pire que le mode habituel de l’Apple II. Bleus/violet baveux, alors que normalement les couleurs de la carte sont nettes.
"l'ordinateur et l'homme sont les deux opposés les plus intégraux qui existent. L'homme est lent, peu rigoureux et très intuitif. L'ordinateur est super rapide, très rigoureux et complètement con."

Nikass
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 1147
Inscription : 12 nov. 2015 23:00
Localisation : trouducul du 31 et 34 aux lunes bleues

Re: Probleme carte Le Chat Mauve

Message par Nikass » 23 mars 2019 09:34

Dis, je ne sais pas pourquoi j'y ai pas pensé mais ce serait pas beaucoup plus simple si tu me l'envoyais, ta carte, et elle repartira avec le reste si t'as pas d'urgence ? parce que pour dépanner, il faudra bien que je compare, et si j'ai pas les deux...


a+

Avatar de l’utilisateur
jvernet
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7714
Inscription : 24 mai 2002 09:57
Localisation : France 69
Contact :

Re: Probleme carte Le Chat Mauve

Message par jvernet » 23 mars 2019 09:35

Je viens de tomber sur ceci:
Mode mixte: uniquement féline IIe et //c avec interface Péritel/RVB. La carte Eve n'est pas compatible avec ce mode. sur le site d’Arnaud Boutillon....

Ca veut dire que je me prend la tête pour rien: il n’u a que la carte Feline et non Eve qui supporte ce mode !!!!

Et pas l’inverse comme je le crus. Il y a quelques mois, j’ai échangé les cartes.....
"l'ordinateur et l'homme sont les deux opposés les plus intégraux qui existent. L'homme est lent, peu rigoureux et très intuitif. L'ordinateur est super rapide, très rigoureux et complètement con."

Nikass
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 1147
Inscription : 12 nov. 2015 23:00
Localisation : trouducul du 31 et 34 aux lunes bleues

Re: Probleme carte Le Chat Mauve

Message par Nikass » 23 mars 2019 09:37

:lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol:

(bon, allez, le premier qu'en n'a jamais fait une du genre lève le doigt)

Avatar de l’utilisateur
jvernet
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7714
Inscription : 24 mai 2002 09:57
Localisation : France 69
Contact :

Re: Probleme carte Le Chat Mauve

Message par jvernet » 23 mars 2019 10:27

en fait, c'est chiant: la EVE possède de bon modes videos (mais pas utilisés), et pas le mixed mode. La carte Feline, moins chère, ne propose plus ces mdoes vidéo, mais est compatible avec le mixed mode.

Feline:
- Les deux modes classiques déja présents sur l'ancien Apple I l + : Basse Résolution 40 x 48/16 couleurs et Haute Résolution 280 x 192/ 6 couleurs limitées.
- Le mode Double Basse Résolution 80 x 4 8 / 1 6 couleurs.

- Les modes Double Haute Résolution: 560 x 192/2 couleurs et 140 x 192/16 couleurs.
Une particularité: il est possible de mélanger sur une même image des parties d'écran en 560 x 192/2 couleurs et 140x192 16 couleurs (Mixed Mode).

Eve: ajoute les modes suivants:
Aux modes standard, Apple IIe
- 280x192 en N&B
- 280x192 6 couleurs classique, mais possibilité d'afficher les points isolés en blanc sur fond noir ou noir sur fond blanc. Possibilité d'afficher les lignes verticales en pointillés
- 140x192 16 couleurs sans contraintes
- 280x192 en 4 couleurs sans contraintes
-280x192 en 16 couleurs par série de 7 points (façon MO5), background stocké en AUX, pixel en RAM
Et ... pas de mixed mode...
"l'ordinateur et l'homme sont les deux opposés les plus intégraux qui existent. L'homme est lent, peu rigoureux et très intuitif. L'ordinateur est super rapide, très rigoureux et complètement con."

Avatar de l’utilisateur
Fabrice Montupet
Administrateur
Administrateur
Messages : 10700
Inscription : 17 mai 2002 11:39
Localisation : Nevers - France

Re: Probleme carte Le Chat Mauve

Message par Fabrice Montupet » 23 mars 2019 16:29

Bon, voila le problème de mode graphique résolu ^_^
Je suis content de voir que le conseil concernant les contacts des broches sur supports de CI a résolu ton soucis de pixels parasites :)
Un bon nettoyage s'impose quand même.

Nikass
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 1147
Inscription : 12 nov. 2015 23:00
Localisation : trouducul du 31 et 34 aux lunes bleues

Re: Probleme carte Le Chat Mauve

Message par Nikass » 23 mars 2019 19:12

Tiens, Fabrice, t'as déjà dû avoir le problème, toi... je repensais à l'histoire du reverse-engineering de la 82S100. Pas compliqué en soi de faire le machin qui donne la table de vérité du circuit, y'a pas de bouclages, mais là où ça se complique, c'est que le tableau de Karnaugh résultant, à la main, ça va pas être drôle pour retrouver les équations logiques pour reprogrammer quelque chose, enfin, refaire le jedec file, quoi.

Bon, j'admets qu'en émulation, on peut toujours s'en tirer ROM-style avec le bon gros tableau brut, mais à supposer qu'on veuille refaire une carte avec un PLD quelconque...

J'ai cherché un peu des programmes qui feraient ça automatiquement, mais j'ai rien trouvé de probant et c'est quand même étonnant qu'il n'y ait pas ça, c'est un classique du genre, même en conception, j'ai dû rater un épisode...

Nicolho, si tu marches toujours dans ton idée: comment tu voulais faire ça ? En émulation, meilleur temps de faire la lookup table, ou le calcul, pour ce que tu veux faire ?

a+

Répondre

Revenir vers « Apple 8 et 16 bits »