Probleme carte Le Chat Mauve

Apple 1, ][, //, IIGS ou /// et 4

Modérateur : Politburo

Répondre
Avatar de l’utilisateur
jvernet
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7714
Inscription : 24 mai 2002 09:57
Localisation : France 69
Contact :

Probleme carte Le Chat Mauve

Message par jvernet » 21 mars 2019 08:27

Hello,

J’ai un curieux soucis avec la carte Le Chat Mauve dans mon Apple IIe: elle ne fait plus le Mixed Mode, dans lequel tu peux mixer du DHGR et du mode B&W 560x192...

Ca marchait il y a quelques semaines, la, je fais des tests pour ApleWin, qui implemente ce mode desormais, pour coir les différences potentielles, et ca ne marche plus!

Depuis quelques selaines, aussi, je remarque que dans certains modes, il y a des pixels parasites de temps en temps, ou des pixels tramblotant/ qui changent de couleurs, en mode DHGR.

Une idée? Fabrice, qui a deja bien investigué une de ses cartes?
Je vais la demonter, verifier que tous les composants sont bien enfoncés. Faire un test RAM, si je trouve un soft pour ce faire.
"l'ordinateur et l'homme sont les deux opposés les plus intégraux qui existent. L'homme est lent, peu rigoureux et très intuitif. L'ordinateur est super rapide, très rigoureux et complètement con."

Avatar de l’utilisateur
snsv6502
Fonctionne à 300 bauds
Fonctionne à 300 bauds
Messages : 89
Inscription : 12 oct. 2018 21:23
Localisation : Nantes

Re: Probleme carte Le Chat Mauve

Message par snsv6502 » 21 mars 2019 20:30

Salut,
Concernant le test de RAM, peut-être AW expander pourrait-il t'aider ?
https://mirrors.apple2.org.za/ftp.apple ... ge/memory/
... ou bien XPS ?
Je ne connais pas trop la carte chat mauve mais si elle propose de la RAM, elle doit bien fonctionner comme les autres cartes de RAM et être commutée de la même manière, non ?
:?
]CALL-151
*

Avatar de l’utilisateur
jvernet
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7714
Inscription : 24 mai 2002 09:57
Localisation : France 69
Contact :

Re: Probleme carte Le Chat Mauve

Message par jvernet » 21 mars 2019 22:00

tests de RAM fait cet AM (via le test de l'Apple II, ou d'autres outils): RAS.
"l'ordinateur et l'homme sont les deux opposés les plus intégraux qui existent. L'homme est lent, peu rigoureux et très intuitif. L'ordinateur est super rapide, très rigoureux et complètement con."

Avatar de l’utilisateur
Fabrice Montupet
Administrateur
Administrateur
Messages : 10699
Inscription : 17 mai 2002 11:39
Localisation : Nevers - France

Re: Probleme carte Le Chat Mauve

Message par Fabrice Montupet » 21 mars 2019 22:19

Disposes-tu d'une version sur laquelle les CI sont sur support? Je dispose d'une Chat Mauve de ce type qui affichait des parasites à sa réception. Après un bon nettoyage de tous les supports et le CI à la bombe KF F2, le problème a disparu.

Avatar de l’utilisateur
jvernet
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7714
Inscription : 24 mai 2002 09:57
Localisation : France 69
Contact :

Re: Probleme carte Le Chat Mauve

Message par jvernet » 21 mars 2019 22:22

Fabrice Montupet a écrit :
21 mars 2019 22:19
Disposes-tu d'une version sur laquelle les CI sont sur support? Je dispose d'une Chat Mauve de ce type qui affichait des parasites à sa réception. Après un bon nettoyage de tous les supports et le CI à la bombe KF F2, le problème a disparu.
Oui tous les CI sur support. je vais essayer ça. Ce qui est curieux, c'est ce mode video qui ne fonctionne plus... Il faut que je trouve du KF F2 (ça se pulverise sur la carte comme ça ?).

C'est quoi le gros composant N825100N K8406 sur la carte ?
"l'ordinateur et l'homme sont les deux opposés les plus intégraux qui existent. L'homme est lent, peu rigoureux et très intuitif. L'ordinateur est super rapide, très rigoureux et complètement con."

Avatar de l’utilisateur
Fabrice Montupet
Administrateur
Administrateur
Messages : 10699
Inscription : 17 mai 2002 11:39
Localisation : Nevers - France

Re: Probleme carte Le Chat Mauve

Message par Fabrice Montupet » 21 mars 2019 22:43

Euh... non :)
Il faut retirer les CIs, nettoyer les supports sur la carte à la bombe KF F2 (ce produit est excellent, mais un produit nettoyant contact électronique classique peut aussi faire l'affaire), nettoyer les broches des CI avec le même produit puis remonter le tout.
Le gros composant est un Gate Array type FPLA, sa référence est N82S100N. C'est le composant maitre de cette carte, il meurt et ta carte est fichue.
Je n'ai pas trouvé le fichier gerber de Chat Mauve pour programmer un autre N82S100N, et ça c'est un problème.

Avatar de l’utilisateur
jvernet
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7714
Inscription : 24 mai 2002 09:57
Localisation : France 69
Contact :

Re: Probleme carte Le Chat Mauve

Message par jvernet » 21 mars 2019 22:58

Est ce que ça vaut le coup que je commande les XX74LSXXX de la carte ? Moins de 20€ l'ensemble sauf 2 pas trouvés chez Conrad ?
Et les petits condos jaunes pourraient être en cause ?
"l'ordinateur et l'homme sont les deux opposés les plus intégraux qui existent. L'homme est lent, peu rigoureux et très intuitif. L'ordinateur est super rapide, très rigoureux et complètement con."

Avatar de l’utilisateur
jvernet
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7714
Inscription : 24 mai 2002 09:57
Localisation : France 69
Contact :

Re: Probleme carte Le Chat Mauve

Message par jvernet » 22 mars 2019 11:57

Démontage de la carte, réenfoncer tous les composants=>plus de pixels parasites. MAIS toujours pas récupéré la fonction Mixed Mode :cry: .

Il va falloir que je trouve une autre carte pour tester si ça provient de l'Apple II ou de la carte.

Et acheter du KF 2.

JV
"l'ordinateur et l'homme sont les deux opposés les plus intégraux qui existent. L'homme est lent, peu rigoureux et très intuitif. L'ordinateur est super rapide, très rigoureux et complètement con."

Nikass
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 1144
Inscription : 12 nov. 2015 23:00
Localisation : trouducul du 31 et 34 aux lunes bleues

Re: Probleme carte Le Chat Mauve

Message par Nikass » 22 mars 2019 13:27

jerôme, quand je t'enverrai tes trucs, si tu veux, je te mets une chat mauve avec, pour essayer, si t'en n'as pas en rab... si ça s'avère être la carte, t'auras qu'à me renvoyer les deux et je te dépannerai la tienne si possible ?

a+

Avatar de l’utilisateur
jvernet
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7714
Inscription : 24 mai 2002 09:57
Localisation : France 69
Contact :

Re: Probleme carte Le Chat Mauve

Message par jvernet » 22 mars 2019 15:11

Volontier, car je ne sais pas ou dans mon merdier se trouve mes cartes de rab. Je sais que j'en ai au moins une en rab, et sans doute plus dans mes machines.... A 50 bornes dans mon box....

:D merci chef. C'est un carte EVE:
Image

Changer tous 74LSqqchose coute moins de 20€, mais est ce que ça aiderait ? Activer ce mode se fait en ecrivant une certaines séquence en RAM.
"l'ordinateur et l'homme sont les deux opposés les plus intégraux qui existent. L'homme est lent, peu rigoureux et très intuitif. L'ordinateur est super rapide, très rigoureux et complètement con."

nicolho
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 33
Inscription : 14 sept. 2018 02:06

Re: Probleme carte Le Chat Mauve

Message par nicolho » 22 mars 2019 16:14

jvernet a écrit :
21 mars 2019 08:27
Ca marchait il y a quelques semaines, la, je fais des tests pour ApleWin, qui implemente ce mode desormais (...)
Merci de l'avoir signalé, c'est intéressant. Comme tu en parles, pourrais-tu déjà nous dire si tu as observé des différences spécifiques avec l'affichage de tes cartes Chat Mauve ? (d'ailleurs, y en a-t-il avec celui obtenu avec la carte Extended 80 colonnes / RGB d'Apple ?)
Fabrice Montupet a écrit :
21 mars 2019 22:43
Je n'ai pas trouvé le fichier gerber de Chat Mauve pour programmer un autre N82S100N, et ça c'est un problème.
A ce propos, justement pour remédier à un tel problème avec (au moins une de) ces puces propriétaires des cartes Chat Mauve (et également parce que ça servirait pour pouvoir en faire des clones), je m'occuperais volontiers de "rétro-ingénierier" (en particulier) celle de la carte Féline. Ça pourrait apporter à la fois les éléments nécessaires pour la reproduire, et aussi utiles pour éventuellement mieux l'émuler.

Alors comme vous êtes apparemment quelques-uns à en posséder plusieurs exemplaires, s'il vous plaît contactez-moi si l'un d'entre vous était intéressé et serait prêt à m'en prêter une quelques temps pour ce faire.

Avatar de l’utilisateur
jvernet
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7714
Inscription : 24 mai 2002 09:57
Localisation : France 69
Contact :

Re: Probleme carte Le Chat Mauve

Message par jvernet » 22 mars 2019 18:45

nicolho a écrit :
22 mars 2019 16:14
jvernet a écrit :
21 mars 2019 08:27
Ca marchait il y a quelques semaines, la, je fais des tests pour ApleWin, qui implemente ce mode desormais (...)
Merci de l'avoir signalé, c'est intéressant. Comme tu en parles, pourrais-tu déjà nous dire si tu as observé des différences spécifiques avec l'affichage de tes cartes Chat Mauve ? (d'ailleurs, y en a-t-il avec celui obtenu avec la carte Extended 80 colonnes / RGB d'Apple ?)
Eh bien, c'est ce que je proposais à Tom, d'AppleWin, de tester... j'avais déja repéré des différences, parfois, mais pas gardé de traces. Par exemple, il me semblait que les menus DazzleDraw sont nets et sans rayures avec EVE.
Après, il y a aussi des softs qui ne demarrent pas en DHGR B&W ou Applewin sur AppleWin mais le font sur la EVE. Et vice versa, d'ailleurs.

Et il manque des modes EVE ou RVB. EVE en particulier a un mode ou tu determine les couleurs par plans de bits (une partie en RAM, l'autre en AUX).
La carte 80 Colonnes ne fait que du 560x192 B&W par defaut. La carte RGB Apple fait du mixed mode. La différence, c'est la qualité de l'image des cartes RVB, beaucoup beaucoup plus nettes, avec des couleurs potables, surtout en utilisant un bon moniteur (celui du IIgs pour moi).

Mais bon, là, les tests tombent à l'eau !
"l'ordinateur et l'homme sont les deux opposés les plus intégraux qui existent. L'homme est lent, peu rigoureux et très intuitif. L'ordinateur est super rapide, très rigoureux et complètement con."

nicolho
Fonctionne à 75 bauds
Fonctionne à 75 bauds
Messages : 33
Inscription : 14 sept. 2018 02:06

Re: Probleme carte Le Chat Mauve

Message par nicolho » 22 mars 2019 20:21

jvernet a écrit :
22 mars 2019 18:45
Eh bien, c'est ce que je proposais à Tom, d'AppleWin, de tester... j'avais déja repéré des différences, parfois, mais pas gardé de traces. Par exemple, il me semblait que les menus DazzleDraw sont nets et sans rayures avec EVE.
Après, il y a aussi des softs qui ne demarrent pas en DHGR B&W ou Applewin sur AppleWin mais le font sur la EVE. Et vice versa, d'ailleurs.
Bien que de telles observations empiriques puissent permettre de déduire certaines particularités et différences pour l'émulateur, une analyse précise du circuit permettrait de connaître exactement les différences d'opérations (un peu comme si on se penchait sur le code source d'un programme au lieu d'uniquement s'en tenir à son comportement).

Dommage que tu n'aies pas réagi à la proposition qui concluait mon message, mais c'est justement pour cette raison que je voulais encourager les possesseurs comme toi, à la fois intéressés par cet aspect spécifique et apparemment plutôt bien lotis en cartes de ce type, à procéder à une telle analyse logique, plus rationnelle et objective, ou bien encore d'en confier un de leurs exemplaires à d'autres qui s'en chargeraient (comme je me proposais de le faire) car ça serait au final bénéfique à plein de niveaux : compréhension, réparation, reproduction, émulation.

Avatar de l’utilisateur
jvernet
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7714
Inscription : 24 mai 2002 09:57
Localisation : France 69
Contact :

Re: Probleme carte Le Chat Mauve

Message par jvernet » 22 mars 2019 21:47

Si ce n'est pas destructif, je pense que la communauté serait interessée par un tel projet. Oublie a carte Feline (tout est soudé), mais la carte EVE tout est sur support. Comme l'indique Fabrice, un composant est spécifique.
Je ne crois pas qu'il existe le moindre schema de cette carte, ni copie, d'ailleurs.

Si je retrouve mes cartes, why not.
"l'ordinateur et l'homme sont les deux opposés les plus intégraux qui existent. L'homme est lent, peu rigoureux et très intuitif. L'ordinateur est super rapide, très rigoureux et complètement con."

Nikass
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 1144
Inscription : 12 nov. 2015 23:00
Localisation : trouducul du 31 et 34 aux lunes bleues

Re: Probleme carte Le Chat Mauve

Message par Nikass » 22 mars 2019 21:49

ben, heu... on n'a pas dit non, non plus, hein, pour le moment c'est pas le sujet. Après, je te rassure, j'ai aussi largement les moyens et les connaissances pour le faire, encore faudrait-il que ça m'intéresse, sinon tu crois quand même pas que j'aurais proposé à Jérôme de lui dépanner la sienne; et les Chat Mauve sont pas vraiment les cartes les plus rares qui soient...

bôf, même soudé, ça pose aucun problème, tu sors tout, tu remontes sur supports, ça se fait sans problème là-dessus.

Je ne sais pas pourquoi tu emploies ce ton-là, mais c'est pas très sympa, d'autant que les gonzes du coin ne sont pas vraiment tombés de la dernière pluie sur ce genre de sujet, bref. Si c'est ton sacerdoce, eh ben t'en achètes une, tu fais le reverse, tu le publies, tu la revends au même prix. Simple, non ? :roll:

a+

Répondre

Revenir vers « Apple 8 et 16 bits »