Apple IIc probleme synchro verticale en composite

Apple 1, ][, //, IIGS ou /// et 4

Modérateur : Politburo

Répondre
Avatar de l’utilisateur
Falkayn
Fonctionne à 300 bauds
Fonctionne à 300 bauds
Messages : 120
Inscription : 10 févr. 2018 14:43

Apple IIc probleme synchro verticale en composite

Message par Falkayn » 29 août 2018 16:58

Bonjour,

Je suis en train de tester un apple 2c et je suis confronté à un problème de synchro verticale. Mais uniquement avec la connection RCA composite.

Parfois l’image est bonne. Sans problème. Mais la plupart du temps le problème apparait. Le fait que l'ordinateur soit "froid" ou "chaud" ne semble pas avoir d'influence... Parfoit l'image est bonne a froid, parfoit à chaud au bout de qq minutes aprés rallumage.

J’ai vérifié les connecteurs et refait un coup de soudure sur les éléments de la carte mère dans la zone video.
La peritel via le chat mauve n'a pas ce problème.

Ici les video que j’ai pris du phénomène.
Note : Sur le moniteur apple (cathodique) le problème de synchro verticale brouille complétement l’affichage.
Sur un ecran LCD on arrive à visualiser l’image et on voit le défilement de la « synchro »

Accueil 2C
https://www.youtube.com/watch?v=bAuVLT_WvsI
Mode sans clavier (test):
https://www.youtube.com/watch?v=-mCZTqHj5wI

Via peritel :
https://www.youtube.com/watch?v=aSXihH1ahAc

Vous savez d’où ça peut venir ?
recherche :
Sharp CE 140F
Sanco TPC 8300 ou clone
Amiga 600


Avatar de l’utilisateur
bernouilli92
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 2681
Inscription : 21 nov. 2012 14:03
Localisation : Ile de France

Re: Apple IIc probleme synchro verticale en composite

Message par bernouilli92 » 29 août 2018 21:43

C’est plutôt un problème de synchro horizontale, non ?
Il faudrait analyser le signal avec oscillo pour voir ce qui cloche au niveau de la synchro.
HP, Casio, Sharp, Psion, quelques TI et divers autres

Nikass
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 882
Inscription : 12 nov. 2015 23:00
Localisation : trouducul du 31 et 34 aux lunes bleues

Re: Apple IIc probleme synchro verticale en composite

Message par Nikass » 30 août 2018 00:39

Ah... ça, j'ai déjà vu :-)

à 90%: ce connecteur RCA, derrière, est une merde finie. Il est en deux parties, en fait l'extérieur de la prise coaxiale, si je me fais comprendre, est à l'origine sertie sur le "châssis" du connecteur.

Ce matériau s'oxyde facilement, et tout le monde tire en tournant pour l'extraire, moralité, elle en vient à se dessertir et à tourner. C'est pas facile à voir au doigt, mais avec un connecteur qui serre un peu, c'est évident. Avec le temps, ça s'oxyde entre les deux bouts: la connexion de masse est largement défectueuse voire inexistante et ça donne ça. C'est vrai aussi sur les II normaux, mais je ne sais pas pourquoi, c'est moins visible/fréquent... donc il faut déjà chercher par là. Quitte à te refaire une masse quelque part pour essayer... ça fait un bail, il me semble que bien décapé, on peut ressouder la collerette. T'es persuadé qu'il est OK, et il ne l'est pas !

à 10%: je me suis fait avoir sur une démo où on avait besoin d'un long câble RCA. Eh bien, selon la caractéristique du câble, ça ne se passe pas bien, donc si t'as un câble long et pas cher, remplace-le par un court et cher :-) en tout cas un vrai coaxial, pas une merdum de pseudo câble audio chinois qui ne l'est pas.

a+

Avatar de l’utilisateur
Falkayn
Fonctionne à 300 bauds
Fonctionne à 300 bauds
Messages : 120
Inscription : 10 févr. 2018 14:43

Re: Apple IIc probleme synchro verticale en composite

Message par Falkayn » 30 août 2018 08:24

oui j'ai pensé au connecteur et j'ai renforcé la fiche central. avec pince croco et fil j'ai repris la connection en amont de la prise rca pour éliminer cette possibilité. j'ai aussi mis un point de soudure sur la zone de connection de la masse de la prise Rca la prise ronde.

Ça n'a pas résolu le soucis. ni atténuer.
recherche :
Sharp CE 140F
Sanco TPC 8300 ou clone
Amiga 600


Avatar de l’utilisateur
Falkayn
Fonctionne à 300 bauds
Fonctionne à 300 bauds
Messages : 120
Inscription : 10 févr. 2018 14:43

Re: Apple IIc probleme synchro verticale en composite

Message par Falkayn » 30 août 2018 08:41

je pense aussi qu'il y a un problème sur une couleur RGB via la péritel. je vais pouvoir comparer avec un autre 2c d'ici qq jours.

Pour moi le point bizzare est que le phénomène n'apparaît que sur la prise Rca. Donc au moins ça isole le problème sur la partie du traitement du signal composite.

Sauf si ça peut se traduire par un problème sur une couleur RGB de la chat mauve?

Je vais essayer plus tard à voir ça sur oscillo pour la synchro horizontale. Ou prend t'on les 2 points de mesure sur la carte mère ?
recherche :
Sharp CE 140F
Sanco TPC 8300 ou clone
Amiga 600


Avatar de l’utilisateur
Falkayn
Fonctionne à 300 bauds
Fonctionne à 300 bauds
Messages : 120
Inscription : 10 févr. 2018 14:43

Re: Apple IIc probleme synchro verticale en composite

Message par Falkayn » 30 août 2018 08:41

je pense aussi qu'il y a un problème sur une couleur RGB via la péritel. je vais pouvoir comparer avec un autre 2c d'ici qq jours.

Pour moi le point bizzare est que le phénomène n'apparaît que sur la prise Rca. Donc au moins ça isole le problème sur la partie du traitement du signal composite.

Sauf si ça peut se traduire par un problème sur une couleur RGB de la chat mauve?

Je vais essayer plus tard à voir ça sur oscillo pour la synchro horizontale. Ou prend t'on les 2 points de mesure sur la carte mère ?
recherche :
Sharp CE 140F
Sanco TPC 8300 ou clone
Amiga 600


Nikass
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 882
Inscription : 12 nov. 2015 23:00
Localisation : trouducul du 31 et 34 aux lunes bleues

Re: Apple IIc probleme synchro verticale en composite

Message par Nikass » 30 août 2018 09:19

Mouais, ben un problème de synchro ET un problème de couleur, ça commence à faire ! alors regarde déjà la tête de tes rails d'alim. C'est plus tordu, mais bien pollué, ça fait quelquefois des trucs de l'espace...

a+

Avatar de l’utilisateur
Falkayn
Fonctionne à 300 bauds
Fonctionne à 300 bauds
Messages : 120
Inscription : 10 févr. 2018 14:43

Re: Apple IIc probleme synchro verticale en composite

Message par Falkayn » 30 août 2018 09:46

Merci du conseil Nikass. Je vais verifier ça et prendre qq mesure de la tension pour verifier que c'est bien ce qui est prévu.
recherche :
Sharp CE 140F
Sanco TPC 8300 ou clone
Amiga 600


Avatar de l’utilisateur
Falkayn
Fonctionne à 300 bauds
Fonctionne à 300 bauds
Messages : 120
Inscription : 10 févr. 2018 14:43

Re: Apple IIc probleme synchro verticale en composite

Message par Falkayn » 31 août 2018 16:20

J'ai démonté l'alim et nettoyé mais sans changement notable.

Par contre j'ai remarqué qu'en tordant légèrement la carte mère. Le phénomène disparait.
J'ai donc mis une cale sous la CM et remonté stratégiquement certaines visses.
Je suppose que le problème vient d'une piste du PCB qui doit être décollée. Ou une soudure qui pose problème (mais j'en ai ressoudé pas mal quand même). Quand j’aurais une après-midi à perdre, j’observerai à la loupe le PCB, et je ferais des tests de continuité des pistes…
recherche :
Sharp CE 140F
Sanco TPC 8300 ou clone
Amiga 600


Nikass
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 882
Inscription : 12 nov. 2015 23:00
Localisation : trouducul du 31 et 34 aux lunes bleues

Re: Apple IIc probleme synchro verticale en composite

Message par Nikass » 31 août 2018 16:41

Alors là !!!! bon, si tu le vois, c'est que c'est vrai, comme dirait l'autre, mais alors ça doit être une machine qui a été démontée et remontée en force, parce qu'il faut en vouloir quand même pour casser ça... ce sont des machines robustes et même sur les II, avec les slots qui forcent, c'est rarissime, et les PCB sont quand même de très bonne facture.

Tu perdras moins de temps à le tracer au scope, effectivement, parce que tomber dessus par hasard, ça va être chaud. Conseil idiot: grouille-toi de le remettre en panne, parce que si jamais ton PCB se redéforme dans le bon sens et que la panne se barre définitivement, pour la retrouver, tu pourrais bien t'amuser !

a+

Répondre

Revenir vers « Apple 8 et 16 bits »