A réparer une HP50G

Les derniers trucs auxquels vous avez joué, les derniers ordinateurs que vous avez bidouillés.

Modérateur : Politburo

Répondre
Avatar de l’utilisateur
Gege34
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 662
Inscription : 03 oct. 2014 11:19
Localisation : 31

A réparer une HP50G

Message par Gege34 » 18 déc. 2017 17:26

J'avais acheté à gege une HP50G qui avait un problème de clavier sur la 1er ligne (problème connu lors de la vente). Donc ce we je me suis mis en tête de voir ce qui n'aller pas.

Ouverture de la 50G, pour cela il faut une ventouse et "arracher" la vitre qui est sur l'écran, en dessous on trouve 2 vis. Une fois les vis retirées il faut déclipser le reste, j'utilise un médiator pour ne pas abimer les plastiques.
Pour faciliter l'accès il faut dessouder le buzzer et retirer le blindage (film de papier métallisé collé). On se retrouve avec ça :
Image.
Etape suivante : accéder au clavier, il faut retirer les vis et faire sauter les rivets (HP a mis ceinture et bretelle). On le fait avec un petit foret, les vis sont suffisantes pour faire tenir l'ensemble lors du remontage.
Le clavier est composé des touches, elles sont solidaire par bloc (la rangée du haut, les curseurs, les touches alpha, shifts, on, et le reste). Par dessus il y a une feuille plastique noir de protection (poussière) et ensuite le PCB.
Image
Sur ce PCB les touches sont composées du tracé sur le PCB + une capsule métallique qui sert de contacte et de ressort. Le tout maintenu par un film plastique collant blanc.
ImageImage
Le problème sur cette HP, c'est les capsules métalliques qui n'étaient plus exactement au bon endroit et faisaient mauvais contact (voir plus du tout contacte sur les touche F5-F6).
J'ai replacé ces capsules, remonté la HP50G, j'en ai profité pour refaire les soudures du connecteur SD qui détecté mal les carte SD et tout est rentré dans l'ordre.
Juste un petit défaut sur le haut de l'écran, une partie du film noir est resté collé sur la HP plutôt que sur l'écran.
Image
Dernière édition par Gege34 le 19 déc. 2017 09:36, édité 1 fois.
Amiga 1200 (gonflé et customisé), Amiga 1000, Amiga 600 + Vampire 600V2, Commodore 128 et son 1541, Amiga 500
HP 48g (gonflé), 48gx(*2), 49g, 49g+, 50g(*2), WP34S (faite maison)
PSION 5mx 16Mb, Casio FX4000P, Ti Voyage 200, Canon X07(*2) + X710(*2 à réviser)

Tipoucet
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 4192
Inscription : 10 janv. 2009 14:47

Re: A réparer une HP50G

Message par Tipoucet » 18 déc. 2017 17:38

Bravo et merci pour la visite ! L'arrachage de la vitre fait peur. Tu la refixes comment ? ça tient bien après ?
Dominique

Avatar de l’utilisateur
Gege34
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 662
Inscription : 03 oct. 2014 11:19
Localisation : 31

Re: A réparer une HP50G

Message par Gege34 » 18 déc. 2017 17:46

La vitre est tenu par du scotch double face, ça se fait assez facilement en douceur et il suffit de la remettre ça colle toujours, c'est le plus simple de la réparation.
Amiga 1200 (gonflé et customisé), Amiga 1000, Amiga 600 + Vampire 600V2, Commodore 128 et son 1541, Amiga 500
HP 48g (gonflé), 48gx(*2), 49g, 49g+, 50g(*2), WP34S (faite maison)
PSION 5mx 16Mb, Casio FX4000P, Ti Voyage 200, Canon X07(*2) + X710(*2 à réviser)

Avatar de l’utilisateur
bernouilli92
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 4748
Inscription : 21 nov. 2012 14:03
Localisation : Ile de France

Re: A réparer une HP50G

Message par bernouilli92 » 18 déc. 2017 17:56

Et pour les rivets en plastique que tu as cassés ?
HP, Casio, Sharp, Psion, quelques TI et divers autres

Avatar de l’utilisateur
Gege34
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 662
Inscription : 03 oct. 2014 11:19
Localisation : 31

Re: A réparer une HP50G

Message par Gege34 » 18 déc. 2017 18:03

bernouilli92 a écrit :
18 déc. 2017 17:56
Et pour les rivets en plastique que tu as cassés ?
Le PCB est tenu sur le clavier par un rivet plastique + une vis dans le rivet (ceinture + bretelle), j'ai gardé juste les vis c'est suffisant.
Amiga 1200 (gonflé et customisé), Amiga 1000, Amiga 600 + Vampire 600V2, Commodore 128 et son 1541, Amiga 500
HP 48g (gonflé), 48gx(*2), 49g, 49g+, 50g(*2), WP34S (faite maison)
PSION 5mx 16Mb, Casio FX4000P, Ti Voyage 200, Canon X07(*2) + X710(*2 à réviser)

Avatar de l’utilisateur
rogeroge
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 4852
Inscription : 14 mai 2010 21:41
Localisation : Entre Nancy et Bercy : à Torcy

Re: A réparer une HP50G

Message par rogeroge » 18 déc. 2017 19:15

Bonjour.
Beau travail.
Pour la vitre, c'est rassurant de savoir que sa dépose n'est pas ardue.
Il faut être fou pour venir sur ce site mais encore plus fou pour ne pas y revenir !

Avatar de l’utilisateur
Hobiecat
Fonctionne à 9600 bauds
Fonctionne à 9600 bauds
Messages : 3617
Inscription : 06 sept. 2011 14:57
Localisation : Normandie / Antwerpen

Re: A réparer une HP50G

Message par Hobiecat » 18 déc. 2017 21:19

Du beau travail ! Sympa qu'on puisse retaper l'excellent 50 !

Avatar de l’utilisateur
Gege34
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 662
Inscription : 03 oct. 2014 11:19
Localisation : 31

Re: A réparer une HP50G

Message par Gege34 » 18 déc. 2017 21:52

Pour la vitre il y a juste un petit problème, une partie du noir qui fait le tour est resté sur la hp plutôt que sur l'écran. Donc quand on le remet il y a un petit défaut visuel, je vous poste une photo demain.
Amiga 1200 (gonflé et customisé), Amiga 1000, Amiga 600 + Vampire 600V2, Commodore 128 et son 1541, Amiga 500
HP 48g (gonflé), 48gx(*2), 49g, 49g+, 50g(*2), WP34S (faite maison)
PSION 5mx 16Mb, Casio FX4000P, Ti Voyage 200, Canon X07(*2) + X710(*2 à réviser)

Avatar de l’utilisateur
gege
Fonctionne à 14400 bauds
Fonctionne à 14400 bauds
Messages : 7926
Inscription : 31 janv. 2008 15:24
Localisation : Banlieue Paârisienne
Contact :

Re: A réparer une HP50G

Message par gege » 19 déc. 2017 00:06

Hello,
Bravo, tu as des nerfs d'acier !
Te voilà récompensé avec une machine qui fonctionne mieux.
Reste maintenant à la faire travailler...

Il me reste 2 machines de ce lot (réservées, dont une pour kweeky), il faudra qu'elles partent.
A bientôt
G.E.

Avatar de l’utilisateur
Gege34
Fonctionne à 1200 bauds
Fonctionne à 1200 bauds
Messages : 662
Inscription : 03 oct. 2014 11:19
Localisation : 31

Re: A réparer une HP50G

Message par Gege34 » 19 déc. 2017 09:37

J'ai rajouté la photo de l'écran dans le 1er post.
Amiga 1200 (gonflé et customisé), Amiga 1000, Amiga 600 + Vampire 600V2, Commodore 128 et son 1541, Amiga 500
HP 48g (gonflé), 48gx(*2), 49g, 49g+, 50g(*2), WP34S (faite maison)
PSION 5mx 16Mb, Casio FX4000P, Ti Voyage 200, Canon X07(*2) + X710(*2 à réviser)

Répondre

Revenir vers « A quoi t'as joué hier ? »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Bing [Bot] et 5 invités